{"answers":{"affected":"3 open source packages ship an affected version, including datasette. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-40570 in the wild and no public exploit code.","fix":"Upgrade datasette to 1.0a4 or later.","what":"CVE-2023-40570 is a medium-severity vulnerability in simonw datasette, published on 25 Aug 2023."},"fix_prompt":"Check this codebase for CVE-2023-40570 and fix it if it is affected.\n\nWhat it is: CVE-2023-40570 is a medium-severity vulnerability in simonw datasette, published on 25 Aug 2023. \nExploitation: There is no known exploitation of CVE-2023-40570 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- datasette (PyPI): affected all versions; no fix listed\n- datasette (PyPI): affected from 1.0a0; fixed in 1.0a4\n- datasette (PyPI): affected from 1.0a0; fixed in 1.0a4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-40570/ (Markdown: https://insights.sbomify.com/CVE-2023-40570/index.md)","id":"CVE-2023-40570","markdown":"https://insights.sbomify.com/CVE-2023-40570/index.md","name":"CVE-2023-40570","record":{"aliases":["GHSA-7ch3-7pp7-7cpq","PYSEC-2023-154"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"datasette","vendor":"datasette"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-213","name":"Exposure of Sensitive Information Due to Incompatible Policies"}],"description":"Datasette is an open source multi-tool for exploring and publishing data. This bug affects Datasette instances running a Datasette 1.0 alpha - 1.0a0, 1.0a1, 1.0a2 or 1.0a3 - in an online accessible location but with authentication enabled using a plugin such as datasette-auth-passwords. The `/-/api` API explorer endpoint could reveal the names of both databases and tables - but not their contents - to an unauthenticated user. Datasette 1.0a4 has a fix for this issue. This will block access to the API explorer but will still allow access to the Datasette read or write JSON APIs, as those use different URL patterns within the Datasette `/database` hierarchy. This issue is patched in version 1.0a4.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Datasette 1.0 alpha series leaks names of databases and tables to unauthenticated users","id":"CVE-2023-40570","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":null,"year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"weblogic-framework Deserialization of Untrusted Data vulnerability","id":"CVE-2023-40571"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":[],"package":"datasette","purl":"pkg:pypi/datasette","source":"PYSEC-2023-154"},{"ecosystem":"PyPI","fixed":["1.0a4"],"introduced":["1.0a0"],"last_affected":[],"package":"datasette","purl":null,"source":"GHSA-7ch3-7pp7-7cpq"},{"ecosystem":"PyPI","fixed":["1.0a4"],"introduced":["1.0a0"],"last_affected":[],"package":"datasette","purl":"pkg:pypi/datasette","source":"GHSA-7ch3-7pp7-7cpq"}],"prev":{"headline":"Out-Of-Bounds Write in FreeRDP","id":"CVE-2023-40569"},"products":["datasette"],"published":"2023-08-25","related":[{"cvss_score":7.2,"headline":"Reflected cross-site scripting issue in Datasette","id":"CVE-2021-32670","kev_date_added":null,"published":"2021-06-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-02","vendors":["simonw"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2023-40570/"}