# CVE-2023-40570: Datasette 1.0 alpha series leaks names of databases and tables to unauthenticated users


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 25 Aug 2023
- **Updated:** 2 Oct 2024
- **Also known as:** GHSA-7ch3-7pp7-7cpq, PYSEC-2023-154

## What is CVE-2023-40570?

CVE-2023-40570 is a medium-severity vulnerability in simonw datasette, published on 25 Aug 2023. 

### Official description

Datasette is an open source multi-tool for exploring and publishing data. This bug affects Datasette instances running a Datasette 1.0 alpha - 1.0a0, 1.0a1, 1.0a2 or 1.0a3 - in an online accessible location but with authentication enabled using a plugin such as datasette-auth-passwords. The `/-/api` API explorer endpoint could reveal the names of both databases and tables - but not their contents - to an unauthenticated user. Datasette 1.0a4 has a fix for this issue. This will block access to the API explorer but will still allow access to the Datasette read or write JSON APIs, as those use different URL patterns within the Datasette `/database` hierarchy. This issue is patched in version 1.0a4.

Weakness: CWE-213 (Exposure of Sensitive Information Due to Incompatible Policies)

## Which versions are affected by CVE-2023-40570?

3 open source packages ship an affected version, including datasette. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `datasette` | PyPI | All versions | None |
| `datasette` | PyPI | From 1.0a0 | 1.0a4 |
| `datasette` | PyPI | From 1.0a0 | 1.0a4 |

Products: Datasette Datasette.

## How do I fix CVE-2023-40570?

Upgrade datasette to 1.0a4 or later.

## Is CVE-2023-40570 being exploited?

There is no known exploitation of CVE-2023-40570 in the wild and no public exploit code.

## Other vulnerabilities in simonw datasette

- [CVE-2021-32670](https://insights.sbomify.com/CVE-2021-32670/): Reflected cross-site scripting issue in Datasette (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40570 and fix it if it is affected.

What it is: CVE-2023-40570 is a medium-severity vulnerability in simonw datasette, published on 25 Aug 2023. 
Exploitation: There is no known exploitation of CVE-2023-40570 in the wild and no public exploit code.

Affected packages and fixed versions:
- datasette (PyPI): affected all versions; no fix listed
- datasette (PyPI): affected from 1.0a0; fixed in 1.0a4
- datasette (PyPI): affected from 1.0a0; fixed in 1.0a4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40570/ (Markdown: https://insights.sbomify.com/CVE-2023-40570/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40570
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40570
- OSV: https://osv.dev/vulnerability/CVE-2023-40570

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40570/
Summaries are generated and may contain mistakes; the official description above is the record.
