# CVE-2023-40572: XWiki Platform vulnerable to CSRF privilege escalation/RCE via the create action

> Attackers can exploit CSRF to execute scripts and gain remote code execution privileges in XWiki installations.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Aug 2023
- **Updated:** 2 Oct 2024
- **Also known as:** GHSA-4f8m-7h83-9f6m

## What is CVE-2023-40572?

CVE-2023-40572 is a critical vulnerability in Xwiki Xwiki, published on 24 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. The create action is vulnerable to a CSRF attack, allowing script and thus remote code execution when targeting a user with script/programming right, thus compromising the confidentiality, integrity and availability of the whole XWiki installation. When a user with script right views this image and a log message `ERROR foo - Script executed!` appears in the log, the XWiki installation is vulnerable. This has been patched in XWiki 14.10.9 and 15.4RC1 by requiring a CSRF token for the actual page creation.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-40572?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.0-rc-1 | 15.4-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.0-rc-1 | 15.4-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 3.2-milestone-3 | 14.10.9 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 3.2-milestone-3 | 14.10.9 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-40572?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 15.4-rc-1 or 14.10.9.

## Is CVE-2023-40572 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-40572 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40572 and fix it if it is affected.

What it is: CVE-2023-40572 is a critical vulnerability in Xwiki Xwiki, published on 24 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-40572 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.0-rc-1; fixed in 15.4-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.0-rc-1; fixed in 15.4-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 3.2-milestone-3; fixed in 14.10.9
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 3.2-milestone-3; fixed in 14.10.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40572/ (Markdown: https://insights.sbomify.com/CVE-2023-40572/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40572
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40572
- OSV: https://osv.dev/vulnerability/CVE-2023-40572

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40572/
Summaries are generated and may contain mistakes; the official description above is the record.
