CVE-2023-40579 OpenFGA Authorization Bypass

Medium 6.5 Published Updated

Attackers can bypass authorization checks in OpenFGA when using specific model expressions with the ListObjects API.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-40579?

CVE-2023-40579 is a medium-severity authentication bypass vulnerability in openfga, published on 25 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

OpenFGA is an authorization/permission engine built for developers and inspired by Google Zanzibar. Some end users of OpenFGA v1.3.0 or earlier are vulnerable to authorization bypass when calling the ListObjects API. The vulnerability affects customers using `ListObjects` with specific models. The affected models contain expressions of type `rel1 from type1`. This issue has been patched in version 1.3.1.

Weakness: CWE-284

Which versions are affected by CVE-2023-40579?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 1 product.

PackageAffectedFixed in
github.com/openfga/openfga GoAll versions1.3.1
github.com/openfga/openfga GoAll versions1.3.1
github.com/openfga/openfga GoAll versions1.3.1

Products include Openfga Openfga.

How do I fix CVE-2023-40579?

Upgrade github.com/openfga/openfga to 1.3.1 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2023-40579 being exploited?

There is no known exploitation of CVE-2023-40579 in the wild and no public exploit code.

Sources

Also known as GHSA-jcf2-mxr2-gmqp, GO-2023-2028.

Is CVE-2023-40579 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free