# CVE-2023-40579: OpenFGA Authorization Bypass

> Attackers can bypass authorization checks in OpenFGA when using specific model expressions with the ListObjects API.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2023
- **Updated:** 1 Oct 2024
- **Also known as:** GHSA-jcf2-mxr2-gmqp, GO-2023-2028

## What is CVE-2023-40579?

CVE-2023-40579 is a medium-severity authentication bypass vulnerability in openfga, published on 25 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenFGA is an authorization/permission engine built for developers and inspired by Google Zanzibar. Some end users of OpenFGA v1.3.0 or earlier are vulnerable to authorization bypass when calling the ListObjects API. The vulnerability affects customers using `ListObjects` with specific models. The affected models contain expressions of type `rel1 from type1`. This issue has been patched in version 1.3.1.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2023-40579?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openfga/openfga` | Go | All versions | 1.3.1 |
| `github.com/openfga/openfga` | Go | All versions | 1.3.1 |
| `github.com/openfga/openfga` | Go | All versions | 1.3.1 |

Products: Openfga Openfga.

## How do I fix CVE-2023-40579?

Upgrade github.com/openfga/openfga to 1.3.1 or later.

## Is CVE-2023-40579 being exploited?

There is no known exploitation of CVE-2023-40579 in the wild and no public exploit code.

## Other vulnerabilities in openfga

- [CVE-2024-31452](https://insights.sbomify.com/CVE-2024-31452/): OpenFGA Authorization Bypass (high 8.1)
- [CVE-2022-23542](https://insights.sbomify.com/CVE-2022-23542/): OpenFGA Authorization Bypass (high 7.7)
- [CVE-2024-42473](https://insights.sbomify.com/CVE-2024-42473/): OpenFGA Authorization Bypass (high 7.5)
- [CVE-2026-40293](https://insights.sbomify.com/CVE-2026-40293/): OpenFGA Playground Preshared Key Exposure (medium 6.5)
- [CVE-2023-43645](https://insights.sbomify.com/CVE-2023-43645/): Denial of service from circular relationship definitions in OpenFGA (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40579 and fix it if it is affected.

What it is: CVE-2023-40579 is a medium-severity authentication bypass vulnerability in openfga, published on 25 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-40579 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.3.1
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.3.1
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40579/ (Markdown: https://insights.sbomify.com/CVE-2023-40579/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40579
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40579
- OSV: https://osv.dev/vulnerability/CVE-2023-40579

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40579/
Summaries are generated and may contain mistakes; the official description above is the record.
