CVE-2023-40581 yt-dlp command injection when using `%q` in `--exec` on Windows

High 8.4 Published Updated

Remote code execution via command injection in yt-dlp on Windows when using the --exec flag with malicious metadata.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-40581?

CVE-2023-40581 is a high-severity command injection vulnerability in yt-dlp, published on 25 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

yt-dlp is a youtube-dl fork with additional features and fixes. yt-dlp allows the user to provide shell command lines to be executed at various stages in its download steps through the `--exec` flag. This flag allows output template expansion in its argument, so that metadata values may be used in the shell commands. The metadata fields can be combined with the `%q` conversion, which is intended to quote/escape these values so they can be safely passed to the shell. However, the escaping used for `cmd` (the shell used by Python's `subprocess` on Windows) does not properly escape special characters, which can allow for remote code execution if `--exec` is used directly with maliciously crafted remote data. This vulnerability only impacts `yt-dlp` on Windows, and the vulnerability is present regardless of whether `yt-dlp` is run from `cmd` or from `PowerShell`. Support for output template expansion in `--exec`, along with this vulnerable behavior, was added to `yt-dlp` in version 2021.04.11. yt-dlp version 2023.09.24 fixes this issue by properly escaping each special character. `\n` will be replaced by `\r` as no way of escaping it has been found. It is recommended to upgrade yt-dlp to version 2023.09.24 as soon as possible. Also, always be careful when using --exec, because while this specific vulnerability has been patched, using unvalidated input in shell commands is inherently dangerous. For Windows users who are not able to upgrade: 1. Avoid using any output template expansion in --exec other than {} (filepath). 2. If expansion in --exec is needed, verify the fields you are using do not contain ", | or &. 3. Instead of using --exec, write the info json and load the fields from it instead.

Weakness: CWE-78

Which versions are affected by CVE-2023-40581?

3 open source packages ship an affected version, including yt-dlp. It affects 1 product.

PackageAffectedFixed in
yt-dlp PyPIFrom 2021.04.112023.09.24
yt-dlp PyPIFrom 2021.04.112023.09.24
yt-dlp PyPIFrom 2021.04.112023.09.24

Products include Yt-Dlp Project Yt-Dlp.

How do I fix CVE-2023-40581?

Upgrade yt-dlp to 2023.09.24 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2023-40581 being exploited?

There is no known exploitation of CVE-2023-40581 in the wild and no public exploit code.

Sources

Also known as GHSA-42h4-v29r-42qg, PYSEC-2026-2064.

Is CVE-2023-40581 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free