# CVE-2023-40581: yt-dlp command injection when using `%q` in `--exec` on Windows

> Remote code execution via command injection in yt-dlp on Windows when using the --exec flag with malicious metadata.

- **Severity:** High 8.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Sep 2023
- **Updated:** 24 Sep 2024
- **Also known as:** GHSA-42h4-v29r-42qg, PYSEC-2026-2064

## What is CVE-2023-40581?

CVE-2023-40581 is a high-severity command injection vulnerability in yt-dlp, published on 25 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

yt-dlp is a youtube-dl fork with additional features and fixes. yt-dlp allows the user to provide shell command lines to be executed at various stages in its download steps through the `--exec` flag. This flag allows output template expansion in its argument, so that metadata values may be used in the shell commands. The metadata fields can be combined with the `%q` conversion, which is intended to quote/escape these values so they can be safely passed to the shell. However, the escaping used for `cmd` (the shell used by Python's `subprocess` on Windows) does not properly escape special characters, which can allow for remote code execution if `--exec` is used directly with maliciously crafted remote data. This vulnerability only impacts `yt-dlp` on Windows, and the vulnerability is present regardless of whether `yt-dlp` is run from `cmd` or from `PowerShell`. Support for output template expansion in `--exec`, along with this vulnerable behavior, was added to `yt-dlp` in version 2021.04.11. yt-dlp version 2023.09.24 fixes this issue by properly escaping each special character. `\n` will be replaced by `\r` as no way of escaping it has been found. It is recommended to upgrade yt-dlp to version 2023.09.24 as soon as possible. Also, always be careful when using --exec, because while this specific vulnerability has been patched, using unvalidated input in shell commands is inherently dangerous. For Windows users who are not able to upgrade: 1. Avoid using any output template expansion in --exec other than {} (filepath). 2. If expansion in --exec is needed, verify the fields you are using do not contain ", | or &. 3. Instead of using --exec, write the info json and load the fields from it instead.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2023-40581?

3 open source packages ship an affected version, including yt-dlp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yt-dlp` | PyPI | From 2021.04.11 | 2023.09.24 |
| `yt-dlp` | PyPI | From 2021.04.11 | 2023.09.24 |
| `yt-dlp` | PyPI | From 2021.04.11 | 2023.09.24 |

Products: Yt-Dlp Project Yt-Dlp.

## How do I fix CVE-2023-40581?

Upgrade yt-dlp to 2023.09.24 or later.

## Is CVE-2023-40581 being exploited?

There is no known exploitation of CVE-2023-40581 in the wild and no public exploit code.

## Other vulnerabilities in yt-dlp

- [CVE-2026-26331](https://insights.sbomify.com/CVE-2026-26331/): yt-dlp: Arbitrary Command Injection when using the `--netrc-cmd` option (high 8.8)
- [CVE-2024-22423](https://insights.sbomify.com/CVE-2024-22423/): yt-dlp `--exec` command injection when using `%q` in yt-dlp on Windows (high 8.4)
- [CVE-2026-50023](https://insights.sbomify.com/CVE-2026-50023/): yt-dlp: Dangerous file type creation via insufficient filename sanitization (Bypass of CVE-2024-38519) (high 8.3)
- [CVE-2026-50574](https://insights.sbomify.com/CVE-2026-50574/): yt-dlp: Arbitrary code execution via manifest downloads with aria2c (high 8.3)
- [CVE-2026-55404](https://insights.sbomify.com/CVE-2026-55404/): yt-dlp: Downstream command injection via improper sanitization of yt-dlp --write-link output (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40581 and fix it if it is affected.

What it is: CVE-2023-40581 is a high-severity command injection vulnerability in yt-dlp, published on 25 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-40581 in the wild and no public exploit code.

Affected packages and fixed versions:
- yt-dlp (PyPI): affected from 2021.04.11; fixed in 2023.09.24
- yt-dlp (PyPI): affected from 2021.04.11; fixed in 2023.09.24
- yt-dlp (PyPI): affected from 2021.04.11; fixed in 2023.09.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40581/ (Markdown: https://insights.sbomify.com/CVE-2023-40581/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40581
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40581
- OSV: https://osv.dev/vulnerability/CVE-2023-40581

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40581/
Summaries are generated and may contain mistakes; the official description above is the record.
