# CVE-2023-40582: Command Injection Vulnerability in find-exec


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 30 Aug 2023
- **Updated:** 1 Oct 2024
- **Also known as:** GHSA-95rp-6gqp-6622

## What is CVE-2023-40582?

CVE-2023-40582 is a critical vulnerability in shime find-exec, published on 30 Aug 2023. 

### Official description

find-exec is a utility to discover available shell commands. Versions prior to 1.0.3 did not properly escape user input and are vulnerable to Command Injection via an attacker controlled parameter. As a result, attackers may run malicious shell commands in the context of the running process. This issue has been addressed in version 1.0.3. users are advised to upgrade. Users unable to upgrade should ensure that all input passed to find-exec comes from a trusted source.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2023-40582?

2 open source packages ship an affected version, including find-exec. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `find-exec` | npm | All versions | 1.0.3 |
| `find-exec` | npm | All versions | 1.0.3 |

Products: Find-Exec Project Find-Exec.

## How do I fix CVE-2023-40582?

Upgrade find-exec to 1.0.3 or later.

## Is CVE-2023-40582 being exploited?

There is no known exploitation of CVE-2023-40582 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40582 and fix it if it is affected.

What it is: CVE-2023-40582 is a critical vulnerability in shime find-exec, published on 30 Aug 2023. 
Exploitation: There is no known exploitation of CVE-2023-40582 in the wild and no public exploit code.

Affected packages and fixed versions:
- find-exec (npm): affected all versions; fixed in 1.0.3
- find-exec (npm): affected all versions; fixed in 1.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40582/ (Markdown: https://insights.sbomify.com/CVE-2023-40582/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40582
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40582
- OSV: https://osv.dev/vulnerability/CVE-2023-40582

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40582/
Summaries are generated and may contain mistakes; the official description above is the record.
