# CVE-2023-40583: libp2p nodes vulnerable to OOM attack

> A malicious actor can exhaust memory in go-libp2p nodes via signed peer records, causing a crash and denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2023
- **Updated:** 2 Oct 2024
- **Also known as:** GHSA-gcq9-qqwx-rgj3, GO-2023-2024

## What is CVE-2023-40583?

CVE-2023-40583 is a high-severity denial of service vulnerability in go-libp2p, published on 25 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libp2p is a networking stack and library modularized out of The IPFS Project, and bundled separately for other tools to use. In go-libp2p, by using signed peer records a malicious actor can store an arbitrary amount of data in a remote node’s memory. This memory does not get garbage collected and so the victim can run out of memory and crash. If users of go-libp2p in production are not monitoring memory consumption over time, it could be a silent attack i.e. the attacker could bring down nodes over a period of time (how long depends on the node resources i.e. a go-libp2p node on a virtual server with 4 gb of memory takes about 90 sec to bring down; on a larger server, it might take a bit longer.) This issue was patched in version 0.27.4.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-40583?

3 open source packages ship an affected version, including github.com/libp2p/go-libp2p. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/libp2p/go-libp2p` | Go | All versions | 0.27.4 |
| `github.com/libp2p/go-libp2p` | Go | All versions | 0.27.4 |
| `github.com/libp2p/go-libp2p` | Go | All versions | 0.27.4 |

Products: Protocol Libp2p.

## How do I fix CVE-2023-40583?

Upgrade github.com/libp2p/go-libp2p to 0.27.4 or later.

## Is CVE-2023-40583 being exploited?

There is no known exploitation of CVE-2023-40583 in the wild and no public exploit code.

## Other vulnerabilities in go-libp2p

- [CVE-2026-35457](https://insights.sbomify.com/CVE-2026-35457/): libp2p-rust has unbounded rendezvous DISCOVER cookies enable remote memory exhaustion (high 8.2)
- [CVE-2026-35405](https://insights.sbomify.com/CVE-2026-35405/): libp2p-rendezvous: Unlimited namespace registrations per peer enables OOM DoS on rendezvous servers (high 7.5)
- [CVE-2022-23492](https://insights.sbomify.com/CVE-2022-23492/): go-libp2p denial of service vulnerability from lack of resource management (high 7.5)
- [CVE-2022-23486](https://insights.sbomify.com/CVE-2022-23486/): libp2p-rust denial of service vulnerability from lack of resource management (high 7.5)
- [CVE-2022-23487](https://insights.sbomify.com/CVE-2022-23487/): libp2p denial of service vulnerability from lack of resource management (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40583 and fix it if it is affected.

What it is: CVE-2023-40583 is a high-severity denial of service vulnerability in go-libp2p, published on 25 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-40583 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/libp2p/go-libp2p (Go): affected all versions; fixed in 0.27.4
- github.com/libp2p/go-libp2p (Go): affected all versions; fixed in 0.27.4
- github.com/libp2p/go-libp2p (Go): affected all versions; fixed in 0.27.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40583/ (Markdown: https://insights.sbomify.com/CVE-2023-40583/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40583
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40583
- OSV: https://osv.dev/vulnerability/CVE-2023-40583

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40583/
Summaries are generated and may contain mistakes; the official description above is the record.
