CVE-2023-40588 Discourse DoS via 2FA and Security Key Names

Medium 6.5 Published Updated

A malicious user can cause a denial of service for other users by adding a 2FA or security key with a crafted name.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-40588?

CVE-2023-40588 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 15 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open-source discussion platform. Prior to version 3.1.1 of the `stable` branch and version 3.2.0.beta1 of the `beta` and `tests-passed` branches, a malicious user could add a 2FA or security key with a carefully crafted name to their account and cause a denial of service for other users. The issue is patched in version 3.1.1 of the `stable` branch and version 3.2.0.beta1 of the `beta` and `tests-passed` branches. There are no known workarounds.

Weakness: CWE-770

Which versions are affected by CVE-2023-40588?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.1.1

Products include Discourse Discourse.

How do I fix CVE-2023-40588?

Upgrade discourse to 3.1.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-40588 being exploited?

There is no known exploitation of CVE-2023-40588 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2023-40588, GHSA-2hg5-3xm3-9vvx.

Is CVE-2023-40588 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free