{"answers":{"affected":"4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-40610 exists.","fix":"Upgrade apache-superset to 2.1.2 or later.","what":"CVE-2023-40610 is a medium-severity vulnerability in Apache Superset, published on 27 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-40610 and fix it if it is affected.\n\nWhat it is: CVE-2023-40610 is a medium-severity vulnerability in Apache Superset, published on 27 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-40610 exists.\n\nAffected packages and fixed versions:\n- apache-superset (PyPI): affected all versions; fixed in 2.1.2\n- apache-superset (PyPI): affected all versions; fixed in 2.1.2\n- apache-superset (PyPI): affected all versions; fixed in 2.1.2\n- superset (Bitnami): affected all versions; fixed in 2.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-40610/ (Markdown: https://insights.sbomify.com/CVE-2023-40610/index.md)","id":"CVE-2023-40610","markdown":"https://insights.sbomify.com/CVE-2023-40610/index.md","name":"CVE-2023-40610","record":{"aliases":["BIT-superset-2023-40610","GHSA-f678-j579-4xf5","PYSEC-2026-1173"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Superset","requires_auth":"low_privilege","summary":"Attackers can escalate privileges and modify authentication data via SQL injection in the default examples database connection.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"superset","vendor":"apache"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Improper authorization check and possible privilege escalation on Apache Superset up to but excluding 2.1.2. Using the default examples database connection that allows access to both the examples schema and Apache Superset's metadata database, an attacker using a specially crafted CTE SQL statement could change data on the metadata database. This weakness could result on tampering with the authentication/authorization data.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Apache Superset: Privilege escalation with default examples database","id":"CVE-2023-40610","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:superset","products":["apache:superset"],"type":"privilege_escalation","year":"2023"},"n_packages":4,"n_references":3,"next":{"headline":"Apache Airflow Dag Runs Broken Access Control Vulnerability","id":"CVE-2023-40611"},"packages":[{"ecosystem":"Bitnami","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"superset","purl":"pkg:bitnami/superset","source":"BIT-superset-2023-40610"},{"ecosystem":"PyPI","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"apache-superset","purl":null,"source":"GHSA-f678-j579-4xf5"},{"ecosystem":"PyPI","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"GHSA-f678-j579-4xf5"},{"ecosystem":"PyPI","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"PYSEC-2026-1173"}],"prev":{"headline":"WordPress Contact form 7 Custom validation Plugin \u003c= 1.1.3 is vulnerable to SQL Injection","id":"CVE-2023-40609"},"products":["Apache Superset"],"published":"2023-11-27","related":[{"cvss_score":8.9,"headline":"Apache Superset Insecure Default Initialization of Resource","id":"CVE-2023-27524","kev_date_added":"2024-01-08","published":"2023-04-24"},{"cvss_score":9.8,"headline":"SQL injection vulnerability in chart data API","id":"CVE-2022-27479","kev_date_added":null,"published":"2022-04-13"},{"cvss_score":9.8,"headline":"Deserialization of Untrusted Data in superset","id":"CVE-2018-8021","kev_date_added":null,"published":"2018-11-07"},{"cvss_score":9.6,"headline":"Apache Superset: Stored XSS in Dashboard Title and Chart Title","id":"CVE-2023-49657","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":8.8,"headline":"Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API","id":"CVE-2022-43719","kev_date_added":null,"published":"2023-01-16"},{"cvss_score":8.8,"headline":"Possible SQL Injection when template processing is enabled","id":"CVE-2021-41971","kev_date_added":null,"published":"2021-10-18"},{"cvss_score":8.8,"headline":"Apache Superset OS Command Injection","id":"CVE-2020-13948","kev_date_added":null,"published":"2020-09-17"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-03","vendors":["Apache Software Foundation"]},"summary":"Attackers can escalate privileges and modify authentication data via SQL injection in the default examples database connection.","url":"https://insights.sbomify.com/CVE-2023-40610/"}