# CVE-2023-40610: Apache Superset: Privilege escalation with default examples database

> Attackers can escalate privileges and modify authentication data via SQL injection in the default examples database connection.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Nov 2023
- **Updated:** 3 Jun 2025
- **Also known as:** BIT-superset-2023-40610, GHSA-f678-j579-4xf5, PYSEC-2026-1173

## What is CVE-2023-40610?

CVE-2023-40610 is a medium-severity vulnerability in Apache Superset, published on 27 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper authorization check and possible privilege escalation on Apache Superset up to but excluding 2.1.2. Using the default examples database connection that allows access to both the examples schema and Apache Superset's metadata database, an attacker using a specially crafted CTE SQL statement could change data on the metadata database. This weakness could result on tampering with the authentication/authorization data.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-40610?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 2.1.2 |
| `apache-superset` | PyPI | All versions | 2.1.2 |
| `apache-superset` | PyPI | All versions | 2.1.2 |
| `superset` | Bitnami | All versions | 2.1.2 |

Products: Apache Superset.

## How do I fix CVE-2023-40610?

Upgrade apache-superset to 2.1.2 or later.

## Is CVE-2023-40610 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-40610 exists.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40610 and fix it if it is affected.

What it is: CVE-2023-40610 is a medium-severity vulnerability in Apache Superset, published on 27 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-40610 exists.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 2.1.2
- apache-superset (PyPI): affected all versions; fixed in 2.1.2
- apache-superset (PyPI): affected all versions; fixed in 2.1.2
- superset (Bitnami): affected all versions; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40610/ (Markdown: https://insights.sbomify.com/CVE-2023-40610/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40610
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40610
- OSV: https://osv.dev/vulnerability/CVE-2023-40610

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40610/
Summaries are generated and may contain mistakes; the official description above is the record.
