CVE-2023-40611 Apache Airflow Dag Runs Broken Access Control Vulnerability

Medium 4.3 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2023-40611?

CVE-2023-40611 is a medium-severity vulnerability in Apache Airflow, published on 12 Sep 2023.

Official description

Apache Airflow, versions before 2.7.1, is affected by a vulnerability that allows authenticated and DAG-view authorized Users to modify some DAG run detail values when submitting notes. This could have them alter details such as configuration parameters, start date, etc.

Users should upgrade to version 2.7.1 or later which has removed the vulnerability.

Weakness: CWE-863

Which versions are affected by CVE-2023-40611?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIAll versions2.7.1
apache-airflow PyPIAll versions2.7.1
apache-airflow PyPIAll versions2.7.1
airflow BitnamiAll versions2.7.3

Products include Apache Airflow.

How do I fix CVE-2023-40611?

Upgrade apache-airflow to 2.7.1 or later.

Is CVE-2023-40611 being exploited?

There is no known exploitation of CVE-2023-40611 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2023-40611, GHSA-wpg8-mf6h-gm92, PYSEC-2023-170.

Is CVE-2023-40611 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free