# CVE-2023-40712: Apache Airflow: Secrets can be unmasked in the "Rendered Template"

> Authenticated users can craft URLs to unmask secret configurations in Apache Airflow, exposing sensitive data.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Sep 2023
- **Updated:** 25 Sep 2024
- **Also known as:** BIT-airflow-2023-40712, GHSA-mjqh-v5f2-g2mw, PYSEC-2023-171

## What is CVE-2023-40712?

CVE-2023-40712 is a medium-severity vulnerability in Apache Airflow, published on 12 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow, versions before 2.7.1, is affected by a vulnerability that allows authenticated users who have access to see the task/dag in the UI, to craft a URL, which could lead to unmasking the secret configuration of the task that otherwise would be masked in the UI.

Users are strongly advised to upgrade to version 2.7.1 or later which has removed the vulnerability.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-40712?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.7.1 |
| `apache-airflow` | PyPI | All versions | 2.7.1 |
| `apache-airflow` | PyPI | All versions | 2.7.1 |
| `airflow` | Bitnami | All versions | 2.7.1 |

Products: Apache Airflow.

## How do I fix CVE-2023-40712?

Upgrade apache-airflow to 2.7.1 or later.

## Is CVE-2023-40712 being exploited?

There is no known exploitation of CVE-2023-40712 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-40712 and fix it if it is affected.

What it is: CVE-2023-40712 is a medium-severity vulnerability in Apache Airflow, published on 12 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-40712 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.7.1
- apache-airflow (PyPI): affected all versions; fixed in 2.7.1
- apache-airflow (PyPI): affected all versions; fixed in 2.7.1
- airflow (Bitnami): affected all versions; fixed in 2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-40712/ (Markdown: https://insights.sbomify.com/CVE-2023-40712/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-40712
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-40712
- OSV: https://osv.dev/vulnerability/CVE-2023-40712

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-40712/
Summaries are generated and may contain mistakes; the official description above is the record.
