CVE-2023-41037 Cleartext Signed Message Signature Spoofing in openpgpjs
Attackers can spoof OpenPGP cleartext signatures by adding unsigned text, misleading users who rely on visual inspection rather than verified data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-41037?
CVE-2023-41037 is a medium-severity vulnerability in openpgpjs, published on 29 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
OpenPGP.js is a JavaScript implementation of the OpenPGP protocol. In affected versions OpenPGP Cleartext Signed Messages are cryptographically signed messages where the signed text is readable without special tools. These messages typically contain a "Hash: ..." header declaring the hash algorithm used to compute the signature digest. OpenPGP.js up to v5.9.0 ignored any data preceding the "Hash: ..." texts when verifying the signature. As a result, malicious parties could add arbitrary text to a third-party Cleartext Signed Message, to lead the victim to believe that the arbitrary text was signed. A user or application is vulnerable to said attack vector if it verifies the CleartextMessage by only checking the returned `verified` property, discarding the associated `data` information, and instead _visually trusting_ the contents of the original message. Since `verificationResult.data` would always contain the actual signed data, users and apps that check this information are not vulnerable. Similarly, given a CleartextMessage object, retrieving the data using `getText()` or the `text` field returns only the contents that are considered when verifying the signature. Finally, re-armoring a CleartextMessage object (using `armor()` will also result in a "sanitised" version, with the extraneous text being removed. This issue has been addressed in version 5.10.1 (current stable version) which will reject messages when calling `openpgp.readCleartextMessage()` and in version 4.10.11 (legacy version) which will will reject messages when calling `openpgp.cleartext.readArmored()`. Users are advised to upgrade. Users unable to upgrade should check the contents of `verificationResult.data` to see what data was actually signed, rather than visually trusting the contents of the armored message.
Weakness: CWE-347
Which versions are affected by CVE-2023-41037?
4 open source packages ship an affected version, including openpgp. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openpgp npm | All versions | 4.10.11 |
openpgp npm | All versions | 4.10.11 |
openpgp npm | From 5.0.0 | 5.10.1 |
openpgp npm | From 5.0.0 | 5.10.1 |
Products include Openpgpjs Openpgpjs.
How do I fix CVE-2023-41037?
Upgrade openpgp to a fixed version for your release line: 4.10.11 or 5.10.1.
Is CVE-2023-41037 being exploited?
There is no known exploitation of CVE-2023-41037 in the wild and no public exploit code.
Other vulnerabilities in openpgpjs
Sources
Also known as GHSA-ch3c-v47x-4pgp.