CVE-2023-41042 Discourse DoS via remote theme assets

Medium 4.9 Published Updated

Attackers can cause denial of service by importing remote themes with excessive assets, requiring administrators to upgrade Discourse.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-41042?

CVE-2023-41042 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 15 Sep 2023. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Discourse is an open-source discussion platform. Prior to version 3.1.1 of the `stable` branch and version 3.2.0.beta1 of the `beta` and `tests-passed` branches, importing a remote theme loads their assets into memory without enforcing limits for file size or number of files. The issue is patched in version 3.1.1 of the `stable` branch and version 3.2.0.beta1 of the `beta` and `tests-passed` branches. There are no known workarounds.

Weakness: CWE-770

Which versions are affected by CVE-2023-41042?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.1.1

Products include Discourse Discourse.

How do I fix CVE-2023-41042?

Upgrade discourse to 3.1.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-41042 being exploited?

There is no known exploitation of CVE-2023-41042 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2023-41042, GHSA-2fq5-x3mm-v254.

Is CVE-2023-41042 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free