CVE-2023-41044 Partial path traversal vulnerability in Support Bundle feature of Graylog

Low 3.3 Published Updated

An authenticated admin can read or delete files in sibling directories via path traversal in the Support Bundle feature.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-41044?

CVE-2023-41044 is a low-severity path traversal vulnerability in graylog2-server, published on 31 Aug 2023. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Graylog is a free and open log management platform. A partial path traversal vulnerability exists in Graylog's `Support Bundle` feature. The vulnerability is caused by incorrect user input validation in an HTTP API resource. Graylog's Support Bundle feature allows an attacker with valid Admin role credentials to download or delete files in sibling directories of the support bundle directory. The default `data_dir` in operating system packages (DEB, RPM) is set to `/var/lib/graylog-server`. The data directory for the Support Bundle feature is always `<data_dir>/support-bundle`. Due to the partial path traversal vulnerability, an attacker with valid Admin role credentials can read or delete files in directories that start with a `/var/lib/graylog-server/support-bundle` directory name. The vulnerability would allow the download or deletion of files in the following example directories: `/var/lib/graylog-server/support-bundle-test` and `/var/lib/graylog-server/support-bundlesdirectory`. For the Graylog Docker images, the `data_dir` is set to `/usr/share/graylog/data` by default. This vulnerability is fixed in Graylog version 5.1.3 and later. Users are advised to upgrade. Users unable to upgrade should block all HTTP requests to the following HTTP API endpoints by using a reverse proxy server in front of Graylog. `GET /api/system/debug/support/bundle/download/{filename}` and `DELETE /api/system/debug/support/bundle/{filename}`.

Weakness: CWE-22

Which versions are affected by CVE-2023-41044?

2 open source packages ship an affected version, including org.graylog2:graylog2-server. It affects 1 product.

PackageAffectedFixed in
org.graylog2:graylog2-server MavenFrom 5.1.05.1.3
org.graylog2:graylog2-server MavenFrom 5.1.05.1.3

Products include Graylog Graylog.

How do I fix CVE-2023-41044?

Upgrade org.graylog2:graylog2-server to 5.1.3 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2023-41044 being exploited?

There is no known exploitation of CVE-2023-41044 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-2q4p-f6gf-mqr5.

Is CVE-2023-41044 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free