{"answers":{"affected":"2 open source packages ship an affected version, including org.graylog2:graylog2-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-41044 in the wild and no public exploit code.","fix":"Upgrade org.graylog2:graylog2-server to 5.1.3 or later.","what":"CVE-2023-41044 is a low-severity path traversal vulnerability in graylog2-server, published on 31 Aug 2023. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-41044 and fix it if it is affected.\n\nWhat it is: CVE-2023-41044 is a low-severity path traversal vulnerability in graylog2-server, published on 31 Aug 2023. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-41044 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.graylog2:graylog2-server (Maven): affected from 5.1.0; fixed in 5.1.3\n- org.graylog2:graylog2-server (Maven): affected from 5.1.0; fixed in 5.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-41044/ (Markdown: https://insights.sbomify.com/CVE-2023-41044/index.md)","id":"CVE-2023-41044","markdown":"https://insights.sbomify.com/CVE-2023-41044/index.md","name":"CVE-2023-41044","record":{"aliases":["GHSA-2q4p-f6gf-mqr5"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Graylog log management","requires_auth":"high_privilege","summary":"An authenticated admin can read or delete files in sibling directories via path traversal in the Support Bundle feature.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"graylog","vendor":"graylog"}],"cvss":{"score":3.3,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Graylog is a free and open log management platform. A partial path traversal vulnerability exists in Graylog's `Support Bundle` feature. The vulnerability is caused by incorrect user input validation in an HTTP API resource. Graylog's Support Bundle feature allows an attacker with valid Admin role credentials to download or delete files in sibling directories of the support bundle directory. The default `data_dir` in operating system packages (DEB, RPM) is set to `/var/lib/graylog-server`. The data directory for the Support Bundle feature is always `\u003cdata_dir\u003e/support-bundle`. Due to the partial path traversal vulnerability, an attacker with valid Admin role credentials can read or delete files in directories that start with a `/var/lib/graylog-server/support-bundle` directory name. The vulnerability would allow the download or deletion of files in the following example directories: `/var/lib/graylog-server/support-bundle-test` and `/var/lib/graylog-server/support-bundlesdirectory`. For the Graylog Docker images, the `data_dir` is set to `/usr/share/graylog/data` by default. This vulnerability is fixed in Graylog version 5.1.3 and later. Users are advised to upgrade. Users unable to upgrade should block all HTTP requests to the following HTTP API endpoints by using a reverse proxy server in front of Graylog. `GET /api/system/debug/support/bundle/download/{filename}` and `DELETE /api/system/debug/support/bundle/{filename}`.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2025-08-20","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-08-20T10:31:28Z","kind":"github_poc","ref":"https://github.com/shoucheng3/Graylog2__graylog2-server_CVE-2023-41044_5-1-2","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Partial path traversal vulnerability in Support Bundle feature of Graylog","id":"CVE-2023-41044","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Insecure source port usage for DNS queries in Graylog","id":"CVE-2023-41045"},"packages":[{"ecosystem":"Maven","fixed":["5.1.3"],"introduced":["5.1.0"],"last_affected":[],"package":"org.graylog2:graylog2-server","purl":null,"source":"GHSA-2q4p-f6gf-mqr5"},{"ecosystem":"Maven","fixed":["5.1.3"],"introduced":["5.1.0"],"last_affected":[],"package":"org.graylog2:graylog2-server","purl":"pkg:maven/org.graylog2/graylog2-server","source":"GHSA-2q4p-f6gf-mqr5"}],"prev":{"headline":"Discourse DoS via SvgSprite cache","id":"CVE-2023-41043"},"products":["graylog2-server"],"published":"2023-08-31","related":[{"cvss_score":9.8,"headline":"Information disclosure in n/a","id":"CVE-2021-37759","kev_date_added":null,"published":"2021-07-31"},{"cvss_score":9.8,"headline":"Information disclosure in n/a","id":"CVE-2021-37760","kev_date_added":null,"published":"2021-07-31"},{"cvss_score":9.3,"headline":"Incorrect management of session invalidation vulnerability in Graylog Web Interface","id":"CVE-2026-1435","kev_date_added":null,"published":"2026-02-18"},{"cvss_score":8.8,"headline":"Graylog vulnerable to privilege escalation through API tokens","id":"CVE-2025-53106","kev_date_added":null,"published":"2025-07-02"},{"cvss_score":8.8,"headline":"graylog2-server vulnerable to instantiation of arbitrary classes triggered by API request","id":"CVE-2024-24824","kev_date_added":null,"published":"2024-02-07"},{"cvss_score":8.1,"headline":"Improper Certificate Validation in Graylog","id":"CVE-2020-15813","kev_date_added":null,"published":"2020-07-17"},{"cvss_score":8,"headline":"Graylog Allows Session Takeover via Insufficient HTML Sanitization","id":"CVE-2025-46827","kev_date_added":null,"published":"2025-05-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-27","vendors":["Graylog2"]},"summary":"An authenticated admin can read or delete files in sibling directories via path traversal in the Support Bundle feature.","url":"https://insights.sbomify.com/CVE-2023-41044/"}