# CVE-2023-41044: Partial path traversal vulnerability in Support Bundle feature of Graylog

> An authenticated admin can read or delete files in sibling directories via path traversal in the Support Bundle feature.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2023
- **Updated:** 27 Sep 2024
- **Also known as:** GHSA-2q4p-f6gf-mqr5

## What is CVE-2023-41044?

CVE-2023-41044 is a low-severity path traversal vulnerability in graylog2-server, published on 31 Aug 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Graylog is a free and open log management platform. A partial path traversal vulnerability exists in Graylog's `Support Bundle` feature. The vulnerability is caused by incorrect user input validation in an HTTP API resource. Graylog's Support Bundle feature allows an attacker with valid Admin role credentials to download or delete files in sibling directories of the support bundle directory. The default `data_dir` in operating system packages (DEB, RPM) is set to `/var/lib/graylog-server`. The data directory for the Support Bundle feature is always `<data_dir>/support-bundle`. Due to the partial path traversal vulnerability, an attacker with valid Admin role credentials can read or delete files in directories that start with a `/var/lib/graylog-server/support-bundle` directory name. The vulnerability would allow the download or deletion of files in the following example directories: `/var/lib/graylog-server/support-bundle-test` and `/var/lib/graylog-server/support-bundlesdirectory`. For the Graylog Docker images, the `data_dir` is set to `/usr/share/graylog/data` by default. This vulnerability is fixed in Graylog version 5.1.3 and later. Users are advised to upgrade. Users unable to upgrade should block all HTTP requests to the following HTTP API endpoints by using a reverse proxy server in front of Graylog. `GET /api/system/debug/support/bundle/download/{filename}` and `DELETE /api/system/debug/support/bundle/{filename}`.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-41044?

2 open source packages ship an affected version, including org.graylog2:graylog2-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.graylog2:graylog2-server` | Maven | From 5.1.0 | 5.1.3 |
| `org.graylog2:graylog2-server` | Maven | From 5.1.0 | 5.1.3 |

Products: Graylog Graylog.

## How do I fix CVE-2023-41044?

Upgrade org.graylog2:graylog2-server to 5.1.3 or later.

## Is CVE-2023-41044 being exploited?

There is no known exploitation of CVE-2023-41044 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/Graylog2__graylog2-server_CVE-2023-41044_5-1-2 (github_poc): https://github.com/shoucheng3/Graylog2__graylog2-server_CVE-2023-41044_5-1-2

## Other vulnerabilities in graylog2-server

- [CVE-2021-37759](https://insights.sbomify.com/CVE-2021-37759/): Information disclosure in n/a (critical 9.8)
- [CVE-2021-37760](https://insights.sbomify.com/CVE-2021-37760/): Information disclosure in n/a (critical 9.8)
- [CVE-2026-1435](https://insights.sbomify.com/CVE-2026-1435/): Incorrect management of session invalidation vulnerability in Graylog Web Interface (critical 9.3)
- [CVE-2025-53106](https://insights.sbomify.com/CVE-2025-53106/): Graylog vulnerable to privilege escalation through API tokens (high 8.8)
- [CVE-2024-24824](https://insights.sbomify.com/CVE-2024-24824/): graylog2-server vulnerable to instantiation of arbitrary classes triggered by API request (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41044 and fix it if it is affected.

What it is: CVE-2023-41044 is a low-severity path traversal vulnerability in graylog2-server, published on 31 Aug 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-41044 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.graylog2:graylog2-server (Maven): affected from 5.1.0; fixed in 5.1.3
- org.graylog2:graylog2-server (Maven): affected from 5.1.0; fixed in 5.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41044/ (Markdown: https://insights.sbomify.com/CVE-2023-41044/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41044
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41044
- OSV: https://osv.dev/vulnerability/CVE-2023-41044

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41044/
Summaries are generated and may contain mistakes; the official description above is the record.
