CVE-2023-41046 Velocity execution without script rights in Xwiki platform
Attackers with edit rights can execute Velocity code without script rights, potentially accessing restricted data and escalating privileges.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-41046?
CVE-2023-41046 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 1 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It is possible in XWiki to execute Velocity code without having script right by creating an XClass with a property of type "TextArea" and content type "VelocityCode" or "VelocityWiki". For the former, the syntax of the document needs to be set the `xwiki/1.0` (this syntax doesn't need to be installed). In both cases, when adding the property to an object, the Velocity code is executed regardless of the rights of the author of the property (edit right is still required, though). In both cases, the code is executed with the correct context author so no privileged APIs can be accessed. However, Velocity still grants access to otherwise inaccessible data and APIs that could allow further privilege escalation. At least for "VelocityCode", this behavior is most likely very old but only since XWiki 7.2, script right is a separate right, before that version all users were allowed to execute Velocity and thus this was expected and not a security issue. This has been patched in XWiki 14.10.10 and 15.4 RC1. Users are advised to upgrade. There are no known workarounds.
Weakness: CWE-862
Which versions are affected by CVE-2023-41046?
4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-oldcore Maven | From 15.0-rc-1 | 15.4-rc-1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 15.0-rc-1 | 15.4-rc-1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 7.2 | 14.10.10 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 7.2 | 14.10.10 |
Products include Xwiki Xwiki.
How do I fix CVE-2023-41046?
Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 15.4-rc-1 or 14.10.10.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-41046 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-41046 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-m5m2-h6h9-p2c8.