# CVE-2023-41046: Velocity execution without script rights in Xwiki platform

> Attackers with edit rights can execute Velocity code without script rights, potentially accessing restricted data and escalating privileges.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2023
- **Updated:** 30 Sep 2024
- **Also known as:** GHSA-m5m2-h6h9-p2c8

## What is CVE-2023-41046?

CVE-2023-41046 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 1 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It is possible in XWiki to execute Velocity code without having script right by creating an XClass with a property of type "TextArea" and content type "VelocityCode" or "VelocityWiki". For the former, the syntax of the document needs to be set the `xwiki/1.0` (this syntax doesn't need to be installed). In both cases, when adding the property to an object, the Velocity code is executed regardless of the rights of the author of the property (edit right is still required, though). In both cases, the code is executed with the correct context author so no privileged APIs can be accessed. However, Velocity still grants access to otherwise inaccessible data and APIs that could allow further privilege escalation. At least for "VelocityCode", this behavior is most likely very old but only since XWiki 7.2, script right is a separate right, before that version all users were allowed to execute Velocity and thus this was expected and not a security issue. This has been patched in XWiki 14.10.10 and 15.4 RC1. Users are advised to upgrade. There are no known workarounds.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-41046?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.0-rc-1 | 15.4-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.0-rc-1 | 15.4-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 7.2 | 14.10.10 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 7.2 | 14.10.10 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-41046?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 15.4-rc-1 or 14.10.10.

## Is CVE-2023-41046 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-41046 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41046 and fix it if it is affected.

What it is: CVE-2023-41046 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 1 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-41046 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.0-rc-1; fixed in 15.4-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.0-rc-1; fixed in 15.4-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 7.2; fixed in 14.10.10
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 7.2; fixed in 14.10.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41046/ (Markdown: https://insights.sbomify.com/CVE-2023-41046/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41046
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41046
- OSV: https://osv.dev/vulnerability/CVE-2023-41046

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41046/
Summaries are generated and may contain mistakes; the official description above is the record.
