# CVE-2023-41047: Improper Neutralization of Special Elements Used in a Template Engine in OctoPrint

> Malicious admins can execute arbitrary code via crafted GCODE scripts in OctoPrint, allowing data theft or manipulation.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:A/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Oct 2023
- **Updated:** 19 Sep 2024
- **Also known as:** GHSA-fwfg-vprh-97ph, PYSEC-2023-195

## What is CVE-2023-41047?

CVE-2023-41047 is a medium-severity code injection vulnerability in OctoPrint, published on 9 Oct 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OctoPrint is a web interface for 3D printers. OctoPrint versions up until and including 1.9.2 contain a vulnerability that allows malicious admins to configure a specially crafted GCODE script that will allow code execution during rendering of that script. An attacker might use this to extract data managed by OctoPrint, or manipulate data managed by OctoPrint, as well as execute arbitrary commands with the rights of the OctoPrint process on the server system. OctoPrint versions from 1.9.3 onward have been patched. Administrators of OctoPrint instances are advised to make sure they can trust all other administrators on their instance and to also not blindly configure arbitrary GCODE scripts found online or provided to them by third parties.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2023-41047?

3 open source packages ship an affected version, including octoprint and OctoPrint. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `octoprint` | PyPI | All versions | 1.9.3 |
| `octoprint` | PyPI | All versions | 1.9.3 |
| `OctoPrint` | PyPI | All versions | 1.9.3 |

Products: Octoprint Octoprint.

## How do I fix CVE-2023-41047?

Upgrade octoprint to 1.9.3 or later.

## Is CVE-2023-41047 being exploited?

There is no known exploitation of CVE-2023-41047 in the wild and no public exploit code.

## Other vulnerabilities in OctoPrint

- [CVE-2018-16710](https://insights.sbomify.com/CVE-2018-16710/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-58180](https://insights.sbomify.com/CVE-2025-58180/): OctoPrint is Vulnerable to RCE Attacks via Unsanitized Filename in File Upload (high 7.5)
- [CVE-2022-1430](https://insights.sbomify.com/CVE-2022-1430/): Cross-site Scripting (XSS) - DOM in octoprint/octoprint (high 7.5)
- [CVE-2022-1432](https://insights.sbomify.com/CVE-2022-1432/): Cross-site Scripting (XSS) - Generic in octoprint/octoprint (high 7.5)
- [CVE-2024-32977](https://insights.sbomify.com/CVE-2024-32977/): OctoPrint Authentication Bypass via X-Forwarded-For Header when autologinLocal is enabled (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41047 and fix it if it is affected.

What it is: CVE-2023-41047 is a medium-severity code injection vulnerability in OctoPrint, published on 9 Oct 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-41047 in the wild and no public exploit code.

Affected packages and fixed versions:
- octoprint (PyPI): affected all versions; fixed in 1.9.3
- octoprint (PyPI): affected all versions; fixed in 1.9.3
- OctoPrint (PyPI): affected all versions; fixed in 1.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41047/ (Markdown: https://insights.sbomify.com/CVE-2023-41047/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41047
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41047
- OSV: https://osv.dev/vulnerability/CVE-2023-41047

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41047/
Summaries are generated and may contain mistakes; the official description above is the record.
