# CVE-2023-41049: Improper Neutralization of Script in Attributes in @dcl/single-sign-on-client

> Attackers can execute arbitrary JavaScript via the init function in the Decentraland single sign-on client library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2023
- **Updated:** 1 Oct 2024
- **Also known as:** GHSA-vp4f-wxgw-7x8x

## What is CVE-2023-41049?

CVE-2023-41049 is a high-severity cross-site scripting vulnerability in decentraland single-sign-on-client, published on 1 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@dcl/single-sign-on-client is an open source npm library which deals with single sign on authentication flows. Improper input validation in the `init` function allows arbitrary javascript to be executed using  the `javascript:` prefix. This vulnerability has been patched on version `0.1.0`. Users are advised to upgrade. Users unable to upgrade should limit untrusted user input to the `init` function.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-41049?

2 open source packages ship an affected version, including @dcl/single-sign-on-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@dcl/single-sign-on-client` | npm | All versions | 0.1.0 |
| `@dcl/single-sign-on-client` | npm | All versions | 0.1.0 |

Products: Decentraland Single Sign on Client.

## How do I fix CVE-2023-41049?

Upgrade @dcl/single-sign-on-client to 0.1.0 or later.

## Is CVE-2023-41049 being exploited?

There is no known exploitation of CVE-2023-41049 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41049 and fix it if it is affected.

What it is: CVE-2023-41049 is a high-severity cross-site scripting vulnerability in decentraland single-sign-on-client, published on 1 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-41049 in the wild and no public exploit code.

Affected packages and fixed versions:
- @dcl/single-sign-on-client (npm): affected all versions; fixed in 0.1.0
- @dcl/single-sign-on-client (npm): affected all versions; fixed in 0.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41049/ (Markdown: https://insights.sbomify.com/CVE-2023-41049/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41049
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41049
- OSV: https://osv.dev/vulnerability/CVE-2023-41049

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41049/
Summaries are generated and may contain mistakes; the official description above is the record.
