# CVE-2023-41053: Redis SORT_RO may bypass ACL configuration

> Attackers can bypass ACL restrictions to read unauthorized keys via the SORT_RO command in Redis, requiring an upgrade to patched versions.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Sep 2023
- **Updated:** 13 Feb 2025
- **Also known as:** ALPINE-CVE-2023-41053, BELL-CVE-2023-41053, BIT-keydb-2023-41053, BIT-redis-2023-41053, BIT-valkey-2023-41053, CLEANSTART-2026-NA38099, DEBIAN-CVE-2023-41053, GHSA-q4jr-5p56-4xwc, SUSE-SU-2023:3711-1

## What is CVE-2023-41053?

CVE-2023-41053 is a low-severity missing authorization vulnerability in redis, published on 6 Sep 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Redis is an in-memory database that persists on disk. Redis does not correctly identify keys accessed by `SORT_RO` and as a result may grant users executing this command access to keys that are not explicitly authorized by the ACL configuration. The problem exists in Redis 7.0 or newer and has been fixed in Redis 7.0.13 and 7.2.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2023-41053?

3 open source packages ship an affected version, including redis, keydb and valkey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `redis` | Bitnami | From 7.0.0 | 7.0.13, 7.2.1 |
| `keydb` | Bitnami | From 7.0.0 | 7.0.13, 7.2.1 |
| `valkey` | Bitnami | From 7.0.0 | 7.0.13, 7.2.1 |
| `redis7` | SUSE:Linux Enterprise Module for Server Applications 15 SP5 | All versions | 7.0.8-150500.3.6.1 |
| `redis7` | openSUSE:Leap 15.5 | All versions | 7.0.8-150500.3.6.1 |

Products: Redis Redis.

## How do I fix CVE-2023-41053?

Upgrade redis to a fixed version for your release line: 7.0.13 or 7.2.1.

## Is CVE-2023-41053 being exploited?

There is no known exploitation of CVE-2023-41053 in the wild and no public exploit code.

## Other vulnerabilities in redis

- [CVE-2022-0543](https://insights.sbomify.com/CVE-2022-0543/): Debian-specific Redis Server Lua Sandbox Escape (critical 10.0, exploited in the wild)
- [CVE-2026-23479](https://insights.sbomify.com/CVE-2026-23479/): redis-server use-after-free in unblock client flow may allow remote code execution (high 7.7)
- [CVE-2026-25243](https://insights.sbomify.com/CVE-2026-25243/): redis-server RESTORE invalid memory access may allow remote code execution (high 7.7)
- [CVE-2025-62507](https://insights.sbomify.com/CVE-2025-62507/): Redis: Bug in XACKDEL may lead to stack overflow and potential RCE (high 7.7)
- [CVE-2025-48367](https://insights.sbomify.com/CVE-2025-48367/): Redis DoS Vulnerability due to bad connection error handling (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41053 and fix it if it is affected.

What it is: CVE-2023-41053 is a low-severity missing authorization vulnerability in redis, published on 6 Sep 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-41053 in the wild and no public exploit code.

Affected packages and fixed versions:
- redis (Bitnami): affected from 7.0.0; fixed in 7.0.13, 7.2.1
- keydb (Bitnami): affected from 7.0.0; fixed in 7.0.13, 7.2.1
- valkey (Bitnami): affected from 7.0.0; fixed in 7.0.13, 7.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41053/ (Markdown: https://insights.sbomify.com/CVE-2023-41053/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41053
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41053
- OSV: https://osv.dev/vulnerability/CVE-2023-41053

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41053/
Summaries are generated and may contain mistakes; the official description above is the record.
