{"answers":{"affected":"3 open source packages ship an affected version, including hyper-bump-it. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-41057 in the wild and no public exploit code.","fix":"Upgrade hyper-bump-it to 0.5.1 or later.","what":"CVE-2023-41057 is a medium-severity path traversal vulnerability in plannigan hyper-bump-it, published on 4 Sep 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-41057 and fix it if it is affected.\n\nWhat it is: CVE-2023-41057 is a medium-severity path traversal vulnerability in plannigan hyper-bump-it, published on 4 Sep 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-41057 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- hyper-bump-it (PyPI): affected all versions; fixed in 0.5.1\n- hyper-bump-it (PyPI): affected all versions; fixed in 0.5.1\n- hyper-bump-it (PyPI): affected all versions; fixed in 0.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-41057/ (Markdown: https://insights.sbomify.com/CVE-2023-41057/index.md)","id":"CVE-2023-41057","markdown":"https://insights.sbomify.com/CVE-2023-41057/index.md","name":"CVE-2023-41057","record":{"aliases":["GHSA-xc27-f9q3-4448","PYSEC-2026-1456"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Python version bumping tool","requires_auth":"none","summary":"Attackers can modify files outside the project directory via crafted glob patterns in the configuration file, requiring non-default configuration to bypass confirmation prompts.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"hyper_bump_it","vendor":"plannigan"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"hyper-bump-it is a command line tool for updating the version in project files.`hyper-bump-it` reads a file glob pattern from the configuration file. That is combined with the project root directory to construct a full glob pattern that is used to find files that should be edited. These matched files should be contained within the project root directory, but that is not checked. This could result in changes being written to files outside of the project. The default behaviour of `hyper-bump-it` is to display the planned changes and prompt the user for confirmation before editing any files. However, the configuration file provides a field that can be used cause files to be edited without displaying the prompt. This issue has been fixed in release version 0.5.1. Users are advised to upgrade. Users that are unable to update from vulnerable versions, executing `hyper-bump-it` with the `--interactive` command line argument will ensure that all planned changes are displayed and prompt the user for confirmation before editing any files, even if the configuration file contains `show_confirm_prompt=true`.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in hyper-bump-it","id":"CVE-2023-41057","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"Trigger `beforeFind` not invoked in internal query pipeline in parse-server","id":"CVE-2023-41058"},"packages":[{"ecosystem":"PyPI","fixed":["0.5.1"],"introduced":["0"],"last_affected":[],"package":"hyper-bump-it","purl":null,"source":"GHSA-xc27-f9q3-4448"},{"ecosystem":"PyPI","fixed":["0.5.1"],"introduced":["0"],"last_affected":[],"package":"hyper-bump-it","purl":"pkg:pypi/hyper-bump-it","source":"GHSA-xc27-f9q3-4448"},{"ecosystem":"PyPI","fixed":["0.5.1"],"introduced":["0"],"last_affected":[],"package":"hyper-bump-it","purl":"pkg:pypi/hyper-bump-it","source":"PYSEC-2026-1456"}],"prev":{"headline":"Redis vulnerable to integer overflow in certain payloads","id":"CVE-2023-41056"},"products":["hyper-bump-it"],"published":"2023-09-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-27","vendors":["plannigan"]},"summary":"Attackers can modify files outside the project directory via crafted glob patterns in the configuration file, requiring non-default configuration to bypass confirmation prompts.","url":"https://insights.sbomify.com/CVE-2023-41057/"}