# CVE-2023-41058: Trigger `beforeFind` not invoked in internal query pipeline in parse-server

> Attackers can bypass security restrictions in Parse Server if beforeFind triggers are used for access control, potentially reading unauthorized data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2023
- **Updated:** 30 Sep 2024
- **Also known as:** BIT-parse-2023-41058, GHSA-fcv6-fg5r-jm9q

## What is CVE-2023-41058?

CVE-2023-41058 is a high-severity missing authorization vulnerability in Parseplatform Parse-Server, published on 4 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source backend server. In affected versions the Parse Cloud trigger `beforeFind` is not invoked in certain conditions of `Parse.Query`. This can pose a vulnerability for deployments where the `beforeFind` trigger is used as a security layer to modify the incoming query. The vulnerability has been fixed by refactoring the internal query pipeline for a more concise code structure and implementing a patch to ensure the `beforeFind` trigger is invoked. This fix was introduced in commit `be4c7e23c6` and has been included in releases 6.2.2 and 5.5.5. Users are advised to upgrade. Users unable to upgrade should make use of parse server's security layers to manage access levels with Class-Level Permissions and Object-Level Access Control that should be used instead of custom security layers in Cloud Code triggers.

Weakness: CWE-670 (Always-Incorrect Control Flow Implementation)

## Which versions are affected by CVE-2023-41058?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | From 1.0.0 | 5.5.5 |
| `parse-server` | npm | From 1.0.0 | 5.5.5 |
| `parse-server` | npm | From 6.0.0 | 6.2.2 |
| `parse-server` | npm | From 6.0.0 | 6.2.2 |
| `parse` | Bitnami | All versions | 5.5.5, 6.2.2 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2023-41058?

Upgrade parse-server to a fixed version for your release line: 5.5.5 or 6.2.2.

## Is CVE-2023-41058 being exploited?

There is no known exploitation of CVE-2023-41058 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41058 and fix it if it is affected.

What it is: CVE-2023-41058 is a high-severity missing authorization vulnerability in Parseplatform Parse-Server, published on 4 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-41058 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected from 1.0.0; fixed in 5.5.5
- parse-server (npm): affected from 1.0.0; fixed in 5.5.5
- parse-server (npm): affected from 6.0.0; fixed in 6.2.2
- parse-server (npm): affected from 6.0.0; fixed in 6.2.2
- parse (Bitnami): affected all versions; fixed in 5.5.5, 6.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41058/ (Markdown: https://insights.sbomify.com/CVE-2023-41058/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41058
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41058
- OSV: https://osv.dev/vulnerability/CVE-2023-41058

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41058/
Summaries are generated and may contain mistakes; the official description above is the record.
