# CVE-2023-41080: Apache Tomcat: Open redirect with FORM authentication

> An open redirect vulnerability in Apache Tomcat's FORM authentication allows attackers to redirect users to malicious sites, requiring specific configuration.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Aug 2023
- **Updated:** 29 Oct 2025
- **Also known as:** BIT-tomcat-2023-41080, CLEANSTART-2026-HS79481, CLSA-2024-1735119580, CLSA-2025-1736889411, CLSA-2026-1788248501, DEBIAN-CVE-2023-41080, GHSA-q3mw-pvr8-9ggc, OESA-2023-1632, ROOT-APP-MAVEN-CVE-2023-41080, SUSE-SU-2023:3987-1, UBUNTU-CVE-2023-41080, openSUSE-SU-2024:13256-1

## What is CVE-2023-41080?

CVE-2023-41080 is a medium-severity vulnerability in Apache Tomcat, published on 25 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

URL Redirection to Untrusted Site ('Open Redirect') vulnerability in FORM authentication feature Apache Tomcat.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.0.12, from 9.0.0-M1 through 9.0.79 and from 8.5.0 through 8.5.92.
Older, EOL versions may also be affected.

The vulnerability is limited to the ROOT (default) web application.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2023-41080?

23 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0-M1 | 10.1.13 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0-M1 | 10.1.13 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.0-M11 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.0-M11 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.0 | 8.5.93 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.0 | 8.5.93 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.0-M1 | 9.0.80 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.0-M1 | 9.0.80 |
| `tomcat` | Bitnami | From 8.5.0 | 8.5.93, 9.0.80, 10.1.13 |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.0-M1 | 10.1.13 |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.0-M1 | 10.1.13 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.0-M1 | 11.0.0-M11 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.0-M1 | 11.0.0-M11 |
| `org.apache.tomcat:tomcat` | Maven | From 8.5.0 | 8.5.93 |
| `org.apache.tomcat:tomcat` | Maven | From 8.5.0 | 8.5.93 |
| `org.apache.tomcat:tomcat` | Maven | From 9.0.0-M1 | 9.0.80 |
| `org.apache.tomcat:tomcat` | Maven | From 9.0.0-M1 | 9.0.80 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 10.1.0-M1 | 10.1.13 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 10.1.0-M1 | 10.1.13 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 8.5.0 | 8.5.93 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 8.5.0 | 8.5.93 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 9.0.0-M1 | 9.0.80 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 9.0.0-M1 | 9.0.80 |
| `tomcat` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 9.0.36-3.108.1 |
| `tomcat` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 9.0.36-3.108.1 |
| `tomcat` | openSUSE:Tumbleweed | All versions | 9.0.80-1.1 |

Products: Apache Tomcat, Debian Debian Linux.

## How do I fix CVE-2023-41080?

Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.13, 11.0.0-M11, 8.5.93 or 9.0.80.

## Is CVE-2023-41080 being exploited?

There is no known exploitation of CVE-2023-41080 in the wild and no public exploit code.

Public exploit code:

- https://github.com/sotiak/CVE-2023-41080 (github_poc): https://github.com/sotiak/CVE-2023-41080

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41080 and fix it if it is affected.

What it is: CVE-2023-41080 is a medium-severity vulnerability in Apache Tomcat, published on 25 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-41080 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0-M1; fixed in 10.1.13
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0-M1; fixed in 10.1.13
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.0-M11
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.0-M11
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.0; fixed in 8.5.93
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.0; fixed in 8.5.93
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.0-M1; fixed in 9.0.80
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.0-M1; fixed in 9.0.80
- tomcat (Bitnami): affected from 8.5.0; fixed in 8.5.93, 9.0.80, 10.1.13
- org.apache.tomcat:tomcat (Maven): affected from 10.1.0-M1; fixed in 10.1.13
- org.apache.tomcat:tomcat (Maven): affected from 10.1.0-M1; fixed in 10.1.13
- org.apache.tomcat:tomcat (Maven): affected from 11.0.0-M1; fixed in 11.0.0-M11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41080/ (Markdown: https://insights.sbomify.com/CVE-2023-41080/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41080
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41080
- OSV: https://osv.dev/vulnerability/CVE-2023-41080

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41080/
Summaries are generated and may contain mistakes; the official description above is the record.
