# CVE-2023-41081: Apache Tomcat Connectors: Unexpected use of first declared worker in mod_jk for unmapped request

> Attackers can bypass security constraints or expose status workers via implicit mapping in mod_jk when specific configurations are used.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Sep 2023
- **Updated:** 25 Sep 2024
- **Also known as:** CLSA-2025-1763032400, DEBIAN-CVE-2023-41081, DLA-3580-1, GHSA-4wvr-fq5p-2362, MGASA-2024-0130, SUSE-SU-2024:1198-1, UBUNTU-CVE-2023-41081, USN-6826-1, USN-8369-2

## What is CVE-2023-41081?

CVE-2023-41081 is a high-severity authentication bypass vulnerability in Apache Tomcat Connectors, published on 13 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Important: Authentication Bypass CVE-2023-41081

The mod_jk component of Apache Tomcat Connectors in some circumstances, such as when a configuration included "JkOptions +ForwardDirectories" but the configuration did not       provide explicit mounts for all possible proxied requests, mod_jk would       use an implicit mapping and map the request to the first defined worker. Such an implicit mapping could result in the unintended exposure of the status worker and/or bypass security constraints configured in httpd. As of JK 1.2.49, the implicit mapping functionality has been removed and all mappings must now be via explicit configuration. Only mod_jk is affected by this issue. The ISAPI redirector is not affected.

This issue affects Apache Tomcat Connectors (mod_jk only): from 1.2.0 through 1.2.48.

Users are recommended to upgrade to version 1.2.49, which fixes the issue.

History
2023-09-13 Original advisory

2023-09-28 Updated summary

## Which versions are affected by CVE-2023-41081?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache2-mod_jk` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 1.2.49-7.9.1 |
| `apache2-mod_jk` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 1.2.49-7.9.1 |

Products: Apache Tomcat Connectors.

## How do I fix CVE-2023-41081?

Upgrade to a fixed version.

## Is CVE-2023-41081 being exploited?

There is no known exploitation of CVE-2023-41081 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat Connectors

- [CVE-2024-46544](https://insights.sbomify.com/CVE-2024-46544/): Apache Tomcat Connectors: mod_jk: local users can view and modify configuration (medium 5.9)
- [CVE-2014-8111](https://insights.sbomify.com/CVE-2014-8111/): Missing authorization in n/a (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41081 and fix it if it is affected.

What it is: CVE-2023-41081 is a high-severity authentication bypass vulnerability in Apache Tomcat Connectors, published on 13 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-41081 in the wild and no public exploit code.

Affected product: Apache Tomcat Connectors. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41081/ (Markdown: https://insights.sbomify.com/CVE-2023-41081/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41081
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41081
- OSV: https://osv.dev/vulnerability/CVE-2023-41081

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41081/
Summaries are generated and may contain mistakes; the official description above is the record.
