CVE-2023-41101 Memory corruption in n/a

Critical 9.8 Published Updated

Attackers can trigger buffer overflows in OpenNDS via crafted GET requests, leading to remote code execution or denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-41101?

CVE-2023-41101 is a critical memory corruption vulnerability in n/a, published on 17 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in the captive portal in OpenNDS before version 10.1.3. get_query in http_microhttpd.c does not validate the length of the query string of GET requests. This leads to a stack-based buffer overflow in versions 9.x and earlier, and to a heap-based buffer overflow in versions 10.x and later. Attackers may exploit the issue to crash OpenNDS (Denial-of-Service condition) or to inject and execute arbitrary bytecode (Remote Code Execution). Affected OpenNDS before version 10.1.3 fixed in OpenWrt master and OpenWrt 23.05 on 23. November by updating OpenNDS to version 10.2.0.

Weakness: CWE-787

Which versions are affected by CVE-2023-41101?

It affects 1 product.

Products include Opennds Opennds.

How do I fix CVE-2023-41101?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2023-41101 being exploited?

There is no known exploitation of CVE-2023-41101 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2023-41101, GHSA-75j8-mr4c-4x59.

Is CVE-2023-41101 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free