{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-41101 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2023-41101 is a critical memory corruption vulnerability in n/a, published on 17 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-41101 and fix it if it is affected.\n\nWhat it is: CVE-2023-41101 is a critical memory corruption vulnerability in n/a, published on 17 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-41101 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-41101/ (Markdown: https://insights.sbomify.com/CVE-2023-41101/index.md)","id":"CVE-2023-41101","markdown":"https://insights.sbomify.com/CVE-2023-41101/index.md","name":"CVE-2023-41101","record":{"aliases":["DEBIAN-CVE-2023-41101","GHSA-75j8-mr4c-4x59"],"analysis":{"component_type":"network_device","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenNDS captive portal","requires_auth":"none","summary":"Attackers can trigger buffer overflows in OpenNDS via crafted GET requests, leading to remote code execution or denial of service.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"opennds","vendor":"opennds"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"An issue was discovered in the captive portal in OpenNDS before version 10.1.3. get_query in http_microhttpd.c does not validate the length of the query string of GET requests. This leads to a stack-based buffer overflow in versions 9.x and earlier, and to a heap-based buffer overflow in versions 10.x and later. Attackers may exploit the issue to crash OpenNDS (Denial-of-Service condition) or to inject and execute arbitrary bytecode (Remote Code Execution). Affected OpenNDS before version 10.1.3 fixed in OpenWrt master and OpenWrt 23.05 on 23. November by updating OpenNDS to version 10.2.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2023-41101","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2023"},"n_packages":0,"n_references":4,"next":{"headline":"Denial of service in n/a","id":"CVE-2023-41102"},"packages":[],"prev":{"headline":"hCaptcha for EXT:form Broken Access Control vulnerability","id":"CVE-2023-41100"},"products":["n/a"],"published":"2023-11-17","related":[{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2023-38317","kev_date_added":null,"published":"2024-01-26"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2023-38318","kev_date_added":null,"published":"2024-01-26"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2023-38319","kev_date_added":null,"published":"2024-01-26"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2023-38323","kev_date_added":null,"published":"2024-01-26"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2023-41102","kev_date_added":null,"published":"2023-11-17"},{"cvss_score":5.5,"headline":"Use after free in n/a","id":"CVE-2024-25763","kev_date_added":null,"published":"2024-02-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-04","vendors":["n/a"]},"summary":"Attackers can trigger buffer overflows in OpenNDS via crafted GET requests, leading to remote code execution or denial of service.","url":"https://insights.sbomify.com/CVE-2023-41101/"}