# CVE-2023-41101: Memory corruption in n/a

> Attackers can trigger buffer overflows in OpenNDS via crafted GET requests, leading to remote code execution or denial of service.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Nov 2023
- **Updated:** 4 Sep 2024
- **Also known as:** DEBIAN-CVE-2023-41101, GHSA-75j8-mr4c-4x59

## What is CVE-2023-41101?

CVE-2023-41101 is a critical memory corruption vulnerability in n/a, published on 17 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the captive portal in OpenNDS before version 10.1.3. get_query in http_microhttpd.c does not validate the length of the query string of GET requests. This leads to a stack-based buffer overflow in versions 9.x and earlier, and to a heap-based buffer overflow in versions 10.x and later. Attackers may exploit the issue to crash OpenNDS (Denial-of-Service condition) or to inject and execute arbitrary bytecode (Remote Code Execution). Affected OpenNDS before version 10.1.3 fixed in OpenWrt master and OpenWrt 23.05 on 23. November by updating OpenNDS to version 10.2.0.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2023-41101?

It affects 1 product.


Products: Opennds Opennds.

## How do I fix CVE-2023-41101?

Upgrade to a fixed version.

## Is CVE-2023-41101 being exploited?

There is no known exploitation of CVE-2023-41101 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-38317](https://insights.sbomify.com/CVE-2023-38317/): Command injection in n/a (critical 9.8)
- [CVE-2023-38318](https://insights.sbomify.com/CVE-2023-38318/): Command injection in n/a (critical 9.8)
- [CVE-2023-38319](https://insights.sbomify.com/CVE-2023-38319/): Command injection in n/a (critical 9.8)
- [CVE-2023-38323](https://insights.sbomify.com/CVE-2023-38323/): Command injection in n/a (critical 9.8)
- [CVE-2023-41102](https://insights.sbomify.com/CVE-2023-41102/): Denial of service in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41101 and fix it if it is affected.

What it is: CVE-2023-41101 is a critical memory corruption vulnerability in n/a, published on 17 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-41101 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41101/ (Markdown: https://insights.sbomify.com/CVE-2023-41101/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41101
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41101
- OSV: https://osv.dev/vulnerability/CVE-2023-41101

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41101/
Summaries are generated and may contain mistakes; the official description above is the record.
