CVE-2023-41102 Denial of service in n/a

High 7.5 Published Updated

Memory leaks in OpenNDS captive portal allow attackers to exhaust system memory, causing a denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-41102?

CVE-2023-41102 is a high-severity denial of service vulnerability in n/a, published on 17 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in the captive portal in OpenNDS before version 10.1.3. It has multiple memory leaks due to not freeing up allocated memory. This may lead to a Denial-of-Service condition due to the consumption of all available memory. Affected OpenNDS before version 10.1.3 fixed in OpenWrt master and OpenWrt 23.05 on 23. November by updating OpenNDS to version 10.2.0.

Weakness: CWE-401, CWE-400

Which versions are affected by CVE-2023-41102?

It affects 1 product.

Products include Opennds Opennds.

How do I fix CVE-2023-41102?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-41102 being exploited?

There is no known exploitation of CVE-2023-41102 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2023-41102, GHSA-98jh-839r-xp86.

Is CVE-2023-41102 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free