CVE-2023-41164 Django Denial of service vulnerability in django.utils.encoding.uri_to_iri
Attackers can cause denial of service in Django applications by sending inputs with excessive Unicode characters to the URI conversion utility.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-41164?
CVE-2023-41164 is a high-severity denial of service vulnerability in Djangoproject Django, published on 3 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Django 3.2 before 3.2.21, 4.1 before 4.1.11, and 4.2 before 4.2.5, django.utils.encoding.uri_to_iri() is subject to a potential DoS (denial of service) attack via certain inputs with a very large number of Unicode characters.
Weakness: CWE-1284
Which versions are affected by CVE-2023-41164?
8 open source packages ship an affected version, including django and Django. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | From 3.2.0 | 3.2.21, 4.1.11, 4.2.5 |
django PyPI | From 3.2 | 3.2.21, 4.1.11, 4.2.5 |
django PyPI | From 3.2 | 3.2.21 |
django PyPI | From 4.1 | 4.1.11 |
django PyPI | From 4.2 | 4.2.5 |
Django PyPI | From 3.2 | 3.2.21 |
2 more packages
Django PyPI | From 4.1 | 4.1.11 |
Django PyPI | From 4.2 | 4.2.5 |
Linux distribution packages (10)
python39-django Red Hat:ansible_automation_platform:2.4::el8 | All versions | 0:3.2.21-1.el8ap |
python3x-django Red Hat:ansible_automation_platform:2.4::el8 | All versions | 0:3.2.21-1.el8ap |
python-django Red Hat:ansible_automation_platform:2.4::el9 | All versions | 0:3.2.21-1.el9ap |
python3-django Red Hat:ansible_automation_platform:2.4::el9 | All versions | 0:3.2.21-1.el9ap |
python-Django SUSE:HPE Helion OpenStack 8 | All versions | 1.11.29-3.51.1 |
python-Django SUSE:OpenStack Cloud 8 | All versions | 1.11.29-3.51.1 |
python-Django1 SUSE:OpenStack Cloud 9 | All versions | 1.11.29-3.50.1 |
python-Django SUSE:OpenStack Cloud Crowbar 8 | All versions | 1.11.29-3.51.1 |
python-Django1 SUSE:OpenStack Cloud Crowbar 9 | All versions | 1.11.29-3.50.1 |
python-Django openSUSE:Tumbleweed | All versions | 4.2.5-1.1 |
Products include Djangoproject Django, Fedoraproject Fedora.
How do I fix CVE-2023-41164?
Upgrade django to a fixed version for your release line: 3.2.21, 4.1.11 or 4.2.5.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-41164 being exploited?
There is no known exploitation of CVE-2023-41164 in the wild and no public exploit code.
Other vulnerabilities in Djangoproject Django
- CVE-2026-4277 Privilege abuse in GenericInlineModelAdmin
- CVE-2024-53908 Django SQL injection in HasKey(lhs, rhs) on Oracle
- CVE-2024-42005 Django SQL injection vulnerability
- CVE-2023-31047 Django bypasses validation when using one form field to upload multiple files
- CVE-2022-34265 Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection
Sources
Also known as BIT-django-2023-41164, DEBIAN-CVE-2023-41164, DLA-3558-1, GHSA-7h4p-27mh-hmrw, OESA-2023-1661, PYSEC-2023-225 and 6 more.