# CVE-2023-41164: Django Denial of service vulnerability in django.utils.encoding.uri_to_iri

> Attackers can cause denial of service in Django applications by sending inputs with excessive Unicode characters to the URI conversion utility.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Nov 2023
- **Updated:** 4 Nov 2025
- **Also known as:** BIT-django-2023-41164, DEBIAN-CVE-2023-41164, DLA-3558-1, GHSA-7h4p-27mh-hmrw, OESA-2023-1661, PYSEC-2023-225, RHSA-2023:5208, SUSE-SU-2023:3533-1, SUSE-SU-2023:3580-1, UBUNTU-CVE-2023-41164, USN-6378-1, openSUSE-SU-2024:13198-1

## What is CVE-2023-41164?

CVE-2023-41164 is a high-severity denial of service vulnerability in Djangoproject Django, published on 3 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Django 3.2 before 3.2.21, 4.1 before 4.1.11, and 4.2 before 4.2.5, django.utils.encoding.uri_to_iri() is subject to a potential DoS (denial of service) attack via certain inputs with a very large number of Unicode characters.

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2023-41164?

8 open source packages ship an affected version, including django and Django. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 3.2.0 | 3.2.21, 4.1.11, 4.2.5 |
| `django` | PyPI | From 3.2 | 3.2.21, 4.1.11, 4.2.5 |
| `django` | PyPI | From 3.2 | 3.2.21 |
| `django` | PyPI | From 4.1 | 4.1.11 |
| `django` | PyPI | From 4.2 | 4.2.5 |
| `Django` | PyPI | From 3.2 | 3.2.21 |
| `Django` | PyPI | From 4.1 | 4.1.11 |
| `Django` | PyPI | From 4.2 | 4.2.5 |
| `python39-django` | Red Hat:ansible_automation_platform:2.4::el8 | All versions | 0:3.2.21-1.el8ap |
| `python3x-django` | Red Hat:ansible_automation_platform:2.4::el8 | All versions | 0:3.2.21-1.el8ap |
| `python-django` | Red Hat:ansible_automation_platform:2.4::el9 | All versions | 0:3.2.21-1.el9ap |
| `python3-django` | Red Hat:ansible_automation_platform:2.4::el9 | All versions | 0:3.2.21-1.el9ap |
| `python-Django` | SUSE:HPE Helion OpenStack 8 | All versions | 1.11.29-3.51.1 |
| `python-Django` | SUSE:OpenStack Cloud 8 | All versions | 1.11.29-3.51.1 |
| `python-Django1` | SUSE:OpenStack Cloud 9 | All versions | 1.11.29-3.50.1 |
| `python-Django` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 1.11.29-3.51.1 |
| `python-Django1` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 1.11.29-3.50.1 |
| `python-Django` | openSUSE:Tumbleweed | All versions | 4.2.5-1.1 |

Products: Djangoproject Django, Fedoraproject Fedora.

## How do I fix CVE-2023-41164?

Upgrade django to a fixed version for your release line: 3.2.21, 4.1.11 or 4.2.5.

## Is CVE-2023-41164 being exploited?

There is no known exploitation of CVE-2023-41164 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41164 and fix it if it is affected.

What it is: CVE-2023-41164 is a high-severity denial of service vulnerability in Djangoproject Django, published on 3 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-41164 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 3.2.0; fixed in 3.2.21, 4.1.11, 4.2.5
- django (PyPI): affected from 3.2; fixed in 3.2.21, 4.1.11, 4.2.5
- django (PyPI): affected from 3.2; fixed in 3.2.21
- django (PyPI): affected from 4.1; fixed in 4.1.11
- django (PyPI): affected from 4.2; fixed in 4.2.5
- Django (PyPI): affected from 3.2; fixed in 3.2.21
- Django (PyPI): affected from 4.1; fixed in 4.1.11
- Django (PyPI): affected from 4.2; fixed in 4.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41164/ (Markdown: https://insights.sbomify.com/CVE-2023-41164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41164
- OSV: https://osv.dev/vulnerability/CVE-2023-41164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41164/
Summaries are generated and may contain mistakes; the official description above is the record.
