# CVE-2023-41180: Apache NiFi MiNiFi C++: Incorrect Certificate Validation in InvokeHTTP for MiNiFi C++

> An intermediary can bypass TLS certificate validation in Apache NiFi MiNiFi C++ due to incorrect default settings, allowing man-in-the-middle attacks.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Sep 2023
- **Updated:** 27 Sep 2024
- **Also known as:** GHSA-987j-v8c2-2p35

## What is CVE-2023-41180?

CVE-2023-41180 is a medium-severity vulnerability in Apache NiFi MiNiFi C++, published on 3 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Incorrect certificate validation in InvokeHTTP on Apache NiFi MiNiFi C++ versions 0.13 to 0.14 allows an intermediary to present a forged certificate during TLS handshake negotation. The Disable Peer Verification property of InvokeHTTP was effectively flipped,  disabling verification by default, when using HTTPS.

Mitigation: Set the Disable Peer Verification property of InvokeHTTP to true when using MiNiFi C++ versions 0.13.0 or 0.14.0. Upgrading to MiNiFi C++ 0.15.0 corrects the default behavior.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2023-41180?

It affects 1 product.


Products: Apache Nifi Minifi C\+\+.

## How do I fix CVE-2023-41180?

No fix has been published for CVE-2023-41180 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-41180 being exploited?

There is no known exploitation of CVE-2023-41180 in the wild and no public exploit code.

## Other vulnerabilities in Apache NiFi MiNiFi C++

- [CVE-2021-33191](https://insights.sbomify.com/CVE-2021-33191/): MiNiFi CPP arbitrary script execution is possible on the agent's host machine through the c2 protocol (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41180 and fix it if it is affected.

What it is: CVE-2023-41180 is a medium-severity vulnerability in Apache NiFi MiNiFi C++, published on 3 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-41180 in the wild and no public exploit code.

Affected product: Apache NiFi MiNiFi C++. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41180/ (Markdown: https://insights.sbomify.com/CVE-2023-41180/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41180
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41180
- OSV: https://osv.dev/vulnerability/CVE-2023-41180

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41180/
Summaries are generated and may contain mistakes; the official description above is the record.
