{"answers":{"affected":"3 open source packages ship an affected version, including github.com/answerdev/answer. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4125 exists.","fix":"Upgrade github.com/answerdev/answer to 1.1.0 or later.","what":"CVE-2023-4125 is a high-severity vulnerability in answerdev/answer, published on 3 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-4125 and fix it if it is affected.\n\nWhat it is: CVE-2023-4125 is a high-severity vulnerability in answerdev/answer, published on 3 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4125 exists.\n\nAffected packages and fixed versions:\n- github.com/answerdev/answer (Go): affected all versions; fixed in 1.1.0\n- github.com/answerdev/answer (Go): affected all versions; fixed in 1.1.0\n- github.com/answerdev/answer (Go): affected all versions; fixed in 1.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-4125/ (Markdown: https://insights.sbomify.com/CVE-2023-4125/index.md)","id":"CVE-2023-4125","markdown":"https://insights.sbomify.com/CVE-2023-4125/index.md","name":"CVE-2023-4125","record":{"aliases":["GHSA-j63x-f657-2m9g","GO-2023-2001"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Answer Q\u0026A platform","requires_auth":"low_privilege","summary":"Weak password requirements in Answer allow attackers to guess credentials and take over user accounts.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"answer","vendor":"answer"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-521","name":"Weak Password Requirements"}],"description":"Weak Password Requirements in GitHub repository answerdev/answer prior to v1.1.0.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Weak Password Requirements in answerdev/answer","id":"CVE-2023-4125","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"weak_cryptography","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"Insufficient Session Expiration in answerdev/answer","id":"CVE-2023-4126"},"packages":[{"ecosystem":"Go","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"github.com/answerdev/answer","purl":null,"source":"GHSA-j63x-f657-2m9g"},{"ecosystem":"Go","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"github.com/answerdev/answer","purl":"pkg:golang/github.com/answerdev/answer","source":"GHSA-j63x-f657-2m9g"},{"ecosystem":"Go","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"github.com/answerdev/answer","purl":"pkg:golang/github.com/answerdev/answer","source":"GO-2023-2001"}],"prev":{"headline":"Missing Authorization in answerdev/answer","id":"CVE-2023-4124"},"products":["answerdev/answer"],"published":"2023-08-03","related":[{"cvss_score":9.8,"headline":"Improper Access Control in answerdev/answer","id":"CVE-2023-0744","kev_date_added":null,"published":"2023-02-08"},{"cvss_score":9.3,"headline":"Cross-site Scripting (XSS) - Stored in answerdev/answer","id":"CVE-2023-1244","kev_date_added":null,"published":"2023-03-07"},{"cvss_score":8.8,"headline":"Cross-site Scripting (XSS) - Stored in answerdev/answer","id":"CVE-2023-1241","kev_date_added":null,"published":"2023-03-07"},{"cvss_score":8.3,"headline":"Missing Authentication for Critical Function in answerdev/answer","id":"CVE-2023-4815","kev_date_added":null,"published":"2023-09-07"},{"cvss_score":8.3,"headline":"Cross-site Scripting (XSS) - Stored in answerdev/answer","id":"CVE-2023-1535","kev_date_added":null,"published":"2023-03-21"},{"cvss_score":8.2,"headline":"Cross-site Scripting (XSS) - Stored in answerdev/answer","id":"CVE-2023-0740","kev_date_added":null,"published":"2023-02-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-10","vendors":["answerdev"]},"summary":"Weak password requirements in Answer allow attackers to guess credentials and take over user accounts.","url":"https://insights.sbomify.com/CVE-2023-4125/"}