{"answers":{"affected":"3 open source packages ship an affected version, including apache-airflow-providers-apache-hdfs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-41267 in the wild and no public exploit code.","fix":"Upgrade apache-airflow-providers-apache-hdfs to 4.1.1 or later.","what":"CVE-2023-41267 is a high-severity vulnerability in Apache Airflow HDFS Provider, published on 14 Sep 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-41267 and fix it if it is affected.\n\nWhat it is: CVE-2023-41267 is a high-severity vulnerability in Apache Airflow HDFS Provider, published on 14 Sep 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-41267 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow-providers-apache-hdfs (PyPI): affected all versions; fixed in 4.1.1\n- apache-airflow-providers-apache-hdfs (PyPI): affected all versions; fixed in 4.1.1\n- apache-airflow-providers-apache-hdfs (PyPI): affected all versions; fixed in 4.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-41267/ (Markdown: https://insights.sbomify.com/CVE-2023-41267/index.md)","id":"CVE-2023-41267","markdown":"https://insights.sbomify.com/CVE-2023-41267/index.md","name":"CVE-2023-41267","record":{"aliases":["GHSA-5hj9-m76g-xrc8","PYSEC-2026-1138"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Apache Airflow HDFS Provider","requires_auth":"none","summary":"Incorrect documentation directed users to install a non-existent PyPI package, allowing potential attackers to claim it and execute malicious code.","user_interaction":"required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"airflow_hdfs_provider","vendor":"apache"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"}],"description":"In the Apache Airflow HDFS Provider, versions prior to 4.1.1, a documentation info pointed users to an install incorrect pip package. As this package name was unclaimed, in theory, an attacker could claim this package and provide code that would be executed when this package was installed. The Airflow team has since taken ownership of the package (neutralizing the risk), and fixed the doc strings in version 4.1.1","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache HDFS Provider error message suggested installation of incorrect pip package","id":"CVE-2023-41267","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2023"},"n_packages":3,"n_references":3,"next":{"headline":"Possible stack overflow due to insufficient input validation","id":"CVE-2023-41268"},"packages":[{"ecosystem":"PyPI","fixed":["4.1.1"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-hdfs","purl":null,"source":"GHSA-5hj9-m76g-xrc8"},{"ecosystem":"PyPI","fixed":["4.1.1"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-hdfs","purl":"pkg:pypi/apache-airflow-providers-apache-hdfs","source":"GHSA-5hj9-m76g-xrc8"},{"ecosystem":"PyPI","fixed":["4.1.1"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-hdfs","purl":"pkg:pypi/apache-airflow-providers-apache-hdfs","source":"PYSEC-2026-1138"}],"prev":{"headline":"Qlik Sense Path Traversal","id":"CVE-2023-41266"},"products":["Apache Airflow HDFS Provider"],"published":"2023-09-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Incorrect documentation directed users to install a non-existent PyPI package, allowing potential attackers to claim it and execute malicious code.","url":"https://insights.sbomify.com/CVE-2023-41267/"}