# CVE-2023-41267: Apache HDFS Provider error message suggested installation of incorrect pip package

> Incorrect documentation directed users to install a non-existent PyPI package, allowing potential attackers to claim it and execute malicious code.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Sep 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-5hj9-m76g-xrc8, PYSEC-2026-1138

## What is CVE-2023-41267?

CVE-2023-41267 is a high-severity vulnerability in Apache Airflow HDFS Provider, published on 14 Sep 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In the Apache Airflow HDFS Provider, versions prior to 4.1.1, a documentation info pointed users to an install incorrect pip package. As this package name was unclaimed, in theory, an attacker could claim this package and provide code that would be executed when this package was installed. The Airflow team has since taken ownership of the package (neutralizing the risk), and fixed the doc strings in version 4.1.1

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2023-41267?

3 open source packages ship an affected version, including apache-airflow-providers-apache-hdfs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-apache-hdfs` | PyPI | All versions | 4.1.1 |
| `apache-airflow-providers-apache-hdfs` | PyPI | All versions | 4.1.1 |
| `apache-airflow-providers-apache-hdfs` | PyPI | All versions | 4.1.1 |

Products: Apache Airflow Hdfs Provider.

## How do I fix CVE-2023-41267?

Upgrade apache-airflow-providers-apache-hdfs to 4.1.1 or later.

## Is CVE-2023-41267 being exploited?

There is no known exploitation of CVE-2023-41267 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41267 and fix it if it is affected.

What it is: CVE-2023-41267 is a high-severity vulnerability in Apache Airflow HDFS Provider, published on 14 Sep 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-41267 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-apache-hdfs (PyPI): affected all versions; fixed in 4.1.1
- apache-airflow-providers-apache-hdfs (PyPI): affected all versions; fixed in 4.1.1
- apache-airflow-providers-apache-hdfs (PyPI): affected all versions; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41267/ (Markdown: https://insights.sbomify.com/CVE-2023-41267/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41267
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41267
- OSV: https://osv.dev/vulnerability/CVE-2023-41267

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41267/
Summaries are generated and may contain mistakes; the official description above is the record.
