{"answers":{"affected":"2 open source packages ship an affected version, including apollo-router. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-41317 in the wild and no public exploit code.","fix":"Upgrade apollo-router to 1.29.1 or later.","what":"CVE-2023-41317 is a high-severity denial of service vulnerability in apollographql router, published on 5 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-41317 and fix it if it is affected.\n\nWhat it is: CVE-2023-41317 is a high-severity denial of service vulnerability in apollographql router, published on 5 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-41317 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apollo-router (crates.io): affected from 1.28.0; fixed in 1.29.1\n- apollo-router (crates.io): affected from 1.28.0; fixed in 1.29.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-41317/ (Markdown: https://insights.sbomify.com/CVE-2023-41317/index.md)","id":"CVE-2023-41317","markdown":"https://insights.sbomify.com/CVE-2023-41317/index.md","name":"CVE-2023-41317","record":{"aliases":["GHSA-w8vq-3hf9-xppx"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Apollo Router","requires_auth":"none","summary":"Attackers can crash the Apollo Router by sending anonymous subscription operations when subscriptions are enabled, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"apollo_router","vendor":"apollographql"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-755","name":"Improper Handling of Exceptional Conditions"}],"description":"The Apollo Router is a configurable, high-performance graph router written in Rust to run a federated supergraph that uses Apollo Federation 2. Affected versions are subject to a Denial-of-Service (DoS) type vulnerability which causes the Router to panic and terminate when GraphQL Subscriptions are enabled.  It can be triggered when **all of the following conditions are met**: 1. Running Apollo Router v1.28.0, v1.28.1 or v1.29.0 (\"impacted versions\"); **and** 2. The Supergraph schema provided to the Router (either via Apollo Uplink or explicitly via other configuration) **has a `subscription` type** with root-fields defined; **and** 3. The YAML configuration provided to the Router **has subscriptions enabled** (they are _disabled_ by default), either by setting `enabled: true` _or_ by setting a valid `mode` within the `subscriptions` object (as seen in [subscriptions' documentation](https://www.apollographql.com/docs/router/executing-operations/subscription-support/#router-setup)); **and** 4. An [anonymous](https://spec.graphql.org/draft/#sec-Anonymous-Operation-Definitions) (i.e., un-named) `subscription` operation (e.g., `subscription { ... }`) is received by the Router If **all four** of these criteria are met, the impacted versions will panic and terminate.  There is no data-privacy risk or sensitive-information exposure aspect to this vulnerability. This is fixed in Apollo Router v1.29.1. Users are advised to upgrade. Updating to v1.29.1 should be a clear and simple upgrade path for those running impacted versions.  However, if Subscriptions are **not** necessary for your Graph – but are enabled via configuration — then disabling subscriptions is another option to mitigate the risk.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unnamed \"Subscription\" operation results in Denial-of-Service in apollographql/router","id":"CVE-2023-41317","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Unsafe media served inline on download endpoints in matrix-media-repo","id":"CVE-2023-41318"},"packages":[{"ecosystem":"crates.io","fixed":["1.29.1"],"introduced":["1.28.0"],"last_affected":[],"package":"apollo-router","purl":null,"source":"GHSA-w8vq-3hf9-xppx"},{"ecosystem":"crates.io","fixed":["1.29.1"],"introduced":["1.28.0"],"last_affected":[],"package":"apollo-router","purl":"pkg:cargo/apollo-router","source":"GHSA-w8vq-3hf9-xppx"}],"prev":{"headline":"HTML Injection with email in Tolgee","id":"CVE-2023-41316"},"products":["router"],"published":"2023-09-05","related":[{"cvss_score":7.5,"headline":"Apollo Router's Compressed Payloads do not respect HTTP Payload Limits","id":"CVE-2024-28101","kev_date_added":null,"published":"2024-03-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-30","vendors":["apollographql"]},"summary":"Attackers can crash the Apollo Router by sending anonymous subscription operations when subscriptions are enabled, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2023-41317/"}