# CVE-2023-41317: Unnamed "Subscription" operation results in Denial-of-Service in apollographql/router

> Attackers can crash the Apollo Router by sending anonymous subscription operations when subscriptions are enabled, requiring an upgrade to fix.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Sep 2023
- **Updated:** 30 Sep 2024
- **Also known as:** GHSA-w8vq-3hf9-xppx

## What is CVE-2023-41317?

CVE-2023-41317 is a high-severity denial of service vulnerability in apollographql router, published on 5 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Apollo Router is a configurable, high-performance graph router written in Rust to run a federated supergraph that uses Apollo Federation 2. Affected versions are subject to a Denial-of-Service (DoS) type vulnerability which causes the Router to panic and terminate when GraphQL Subscriptions are enabled.  It can be triggered when **all of the following conditions are met**: 1. Running Apollo Router v1.28.0, v1.28.1 or v1.29.0 ("impacted versions"); **and** 2. The Supergraph schema provided to the Router (either via Apollo Uplink or explicitly via other configuration) **has a `subscription` type** with root-fields defined; **and** 3. The YAML configuration provided to the Router **has subscriptions enabled** (they are _disabled_ by default), either by setting `enabled: true` _or_ by setting a valid `mode` within the `subscriptions` object (as seen in [subscriptions' documentation](https://www.apollographql.com/docs/router/executing-operations/subscription-support/#router-setup)); **and** 4. An [anonymous](https://spec.graphql.org/draft/#sec-Anonymous-Operation-Definitions) (i.e., un-named) `subscription` operation (e.g., `subscription { ... }`) is received by the Router If **all four** of these criteria are met, the impacted versions will panic and terminate.  There is no data-privacy risk or sensitive-information exposure aspect to this vulnerability. This is fixed in Apollo Router v1.29.1. Users are advised to upgrade. Updating to v1.29.1 should be a clear and simple upgrade path for those running impacted versions.  However, if Subscriptions are **not** necessary for your Graph – but are enabled via configuration — then disabling subscriptions is another option to mitigate the risk.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2023-41317?

2 open source packages ship an affected version, including apollo-router. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apollo-router` | crates.io | From 1.28.0 | 1.29.1 |
| `apollo-router` | crates.io | From 1.28.0 | 1.29.1 |

Products: Apollographql Apollo Router.

## How do I fix CVE-2023-41317?

Upgrade apollo-router to 1.29.1 or later.

## Is CVE-2023-41317 being exploited?

There is no known exploitation of CVE-2023-41317 in the wild and no public exploit code.

## Other vulnerabilities in apollographql router

- [CVE-2024-28101](https://insights.sbomify.com/CVE-2024-28101/): Apollo Router's Compressed Payloads do not respect HTTP Payload Limits (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41317 and fix it if it is affected.

What it is: CVE-2023-41317 is a high-severity denial of service vulnerability in apollographql router, published on 5 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-41317 in the wild and no public exploit code.

Affected packages and fixed versions:
- apollo-router (crates.io): affected from 1.28.0; fixed in 1.29.1
- apollo-router (crates.io): affected from 1.28.0; fixed in 1.29.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41317/ (Markdown: https://insights.sbomify.com/CVE-2023-41317/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41317
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41317
- OSV: https://osv.dev/vulnerability/CVE-2023-41317

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41317/
Summaries are generated and may contain mistakes; the official description above is the record.
