CVE-2023-41319 Remote Code Execution in Custom Integration Upload in Fides

High 8.8 Published Updated

Privileged users can execute arbitrary code by bypassing the sandbox in custom integration uploads when custom functions are enabled.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-41319?

CVE-2023-41319 is a high-severity code injection vulnerability in ethyca fides, published on 6 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in a runtime environment, and the enforcement of privacy regulations in code. The Fides webserver API allows custom integrations to be uploaded as a ZIP file. This ZIP file must contain YAML files, but Fides can be configured to also accept the inclusion of custom Python code in it. The custom code is executed in a restricted, sandboxed environment, but the sandbox can be bypassed to execute any arbitrary code. The vulnerability allows the execution of arbitrary code on the target system within the context of the webserver python process owner on the webserver container, which by default is `root`, and leverage that access to attack underlying infrastructure and integrated systems. This vulnerability affects Fides versions `2.11.0` through `2.19.0`. Exploitation is limited to API clients with the `CONNECTOR_TEMPLATE_REGISTER` authorization scope. In the Fides Admin UI this scope is restricted to highly privileged users, specifically root users and users with the owner role. Exploitation is only possible if the security configuration parameter `allow_custom_connector_functions` is enabled by the user deploying the Fides webserver container, either in `fides.toml` or by setting the env var `FIDES__SECURITY__ALLOW_CUSTOM_CONNECTOR_FUNCTIONS=True`. By default this configuration parameter is disabled. The vulnerability has been patched in Fides version `2.19.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. Users unable to upgrade should ensure that `allow_custom_connector_functions` in `fides.toml` and the `FIDES__SECURITY__ALLOW_CUSTOM_CONNECTOR_FUNCTIONS` are both either unset or explicit set to `False`.

Weakness: CWE-94, CWE-693

Which versions are affected by CVE-2023-41319?

3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.

PackageAffectedFixed in
ethyca-fides PyPIFrom 2.11.02.19.0
ethyca-fides PyPIFrom 2.11.02.19.0
ethyca-fides PyPIFrom 2.11.02.19.0

Products include Ethyca Fides.

How do I fix CVE-2023-41319?

Upgrade ethyca-fides to 2.19.0 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2023-41319 being exploited?

There is no known exploitation of CVE-2023-41319 in the wild and no public exploit code.

Sources

Also known as GHSA-p6p2-qq95-vq5h, PYSEC-2026-1345.

Is CVE-2023-41319 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free