# CVE-2023-41330: Unsafe deserialization in knplabs/knp-snappy

> Attacker can achieve remote code execution via PHAR deserialization bypass in KnpLabs Snappy library if they control filename input.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Sep 2023
- **Updated:** 30 Sep 2024
- **Also known as:** GHSA-92rv-4j2h-8mjj

## What is CVE-2023-41330?

CVE-2023-41330 is a critical unsafe deserialization vulnerability in KnpLabs snappy, published on 6 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

knplabs/knp-snappy is a PHP library allowing thumbnail, snapshot or PDF generation from a url or a html page.
## Issue

On March 17th the vulnerability CVE-2023-28115 was disclosed, allowing an attacker to gain remote code execution through PHAR deserialization. Version 1.4.2 added a check `if (\strpos($filename, 'phar://') === 0)` in the `prepareOutput` function to resolve this CVE, however if the user is able to control the second parameter of the `generateFromHtml()` function of Snappy, it will then be passed as the `$filename` parameter in the `prepareOutput()` function. In the original vulnerability, a file name with a `phar://` wrapper could be sent to the `fileExists()` function, equivalent to the `file_exists()` PHP function. This allowed users to trigger a deserialization on arbitrary PHAR files. To fix this issue, the string is now passed to the `strpos()` function and if it starts with `phar://`, an exception is raised. However, PHP wrappers being case insensitive, this patch can be bypassed using `PHAR://` instead of `phar://`. A successful exploitation of this vulnerability allows executing arbitrary code and accessing the underlying filesystem. The attacker must be able to upload a file and the server must be running a PHP version prior to 8. This issue has been addressed in commit `d3b742d61a` which has been included in version 1.4.3. Users are advised to upgrade. Users unable to upgrade should ensure that only trusted users may submit data to the `AbstractGenerator->generate(...)` function.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-41330?

2 open source packages ship an affected version, including knplabs/knp-snappy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `knplabs/knp-snappy` | Packagist | All versions | 1.4.3 |
| `knplabs/knp-snappy` | Packagist | All versions | 1.4.3 |

Products: Knplabs Snappy.

## How do I fix CVE-2023-41330?

Upgrade knplabs/knp-snappy to 1.4.3 or later.

## Is CVE-2023-41330 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-41330 exists.

## Other vulnerabilities in KnpLabs snappy

- [CVE-2023-28115](https://insights.sbomify.com/CVE-2023-28115/): Snappy vulnerable to PHAR deserialization, allowing remote code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41330 and fix it if it is affected.

What it is: CVE-2023-41330 is a critical unsafe deserialization vulnerability in KnpLabs snappy, published on 6 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-41330 exists.

Affected packages and fixed versions:
- knplabs/knp-snappy (Packagist): affected all versions; fixed in 1.4.3
- knplabs/knp-snappy (Packagist): affected all versions; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41330/ (Markdown: https://insights.sbomify.com/CVE-2023-41330/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41330
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41330
- OSV: https://osv.dev/vulnerability/CVE-2023-41330

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41330/
Summaries are generated and may contain mistakes; the official description above is the record.
