CVE-2023-41332 Denial of service via Kubernetes annotations in specific Cilium configurations

Low 3.5 Published Updated

Attackers can cause a denial of service on Cilium nodes by creating workloads with specific annotations when the Layer 7 proxy is disabled.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2023-41332?

CVE-2023-41332 is a low-severity denial of service vulnerability in cilium, published on 26 Sep 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. In Cilium clusters where Cilium's Layer 7 proxy has been disabled, creating workloads with `policy.cilium.io/proxy-visibility` annotations (in Cilium >= v1.13) or `io.cilium.proxy-visibility` annotations (in Cilium <= v1.12) causes the Cilium agent to segfault on the node to which the workload is assigned. Existing traffic on the affected node will continue to flow, but the Cilium agent on the node will not able to process changes to workloads running on the node. This will also prevent workloads from being able to start on the affected node. The denial of service will be limited to the node on which the workload is scheduled, however an attacker may be able to schedule workloads on the node of their choosing, which could lead to targeted attacks. This issue has been resolved in Cilium versions 1.14.2, 1.13.7, and 1.12.14. Users unable to upgrade can avoid this denial of service attack by enabling the Layer 7 proxy.

Weakness: CWE-755

Which versions are affected by CVE-2023-41332?

14 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.

PackageAffectedFixed in
github.com/cilium/cilium GoAll versions1.12.14, 1.13.7, 1.14.2
github.com/cilium/cilium GoAll versions1.12.14
github.com/cilium/cilium GoAll versions1.12.14
github.com/cilium/cilium GoFrom 1.13.01.13.7
github.com/cilium/cilium GoFrom 1.13.01.13.7
github.com/cilium/cilium GoFrom 1.14.01.14.2
8 more packages
github.com/cilium/cilium GoFrom 1.14.01.14.2
cilium BitnamiAll versions1.12.14, 1.13.7, 1.14.2
cilium-operator BitnamiAll versions1.12.14, 1.13.7, 1.14.2
cilium-proxy BitnamiAll versions1.12.14, 1.13.7, 1.14.2
hubble BitnamiAll versions1.12.14, 1.13.7, 1.14.2
hubble-relay BitnamiAll versions1.12.14, 1.13.7, 1.14.2
hubble-ui BitnamiAll versions1.12.14, 1.13.7, 1.14.2
hubble-ui-backend BitnamiAll versions1.12.14, 1.13.7, 1.14.2

Products include Cilium Cilium.

How do I fix CVE-2023-41332?

Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.12.14, 1.13.7 or 1.14.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-41332 being exploited?

There is no known exploitation of CVE-2023-41332 in the wild and no public exploit code.

Sources

Also known as BIT-cilium-2023-41332, BIT-cilium-operator-2023-41332, BIT-cilium-proxy-2023-41332, BIT-hubble-2023-41332, BIT-hubble-relay-2023-41332, BIT-hubble-ui-2023-41332 and 3 more.

Is CVE-2023-41332 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free