# CVE-2023-41332: Denial of service via Kubernetes annotations in specific Cilium configurations

> Attackers can cause a denial of service on Cilium nodes by creating workloads with specific annotations when the Layer 7 proxy is disabled.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2023
- **Updated:** 23 Sep 2024
- **Also known as:** BIT-cilium-2023-41332, BIT-cilium-operator-2023-41332, BIT-cilium-proxy-2023-41332, BIT-hubble-2023-41332, BIT-hubble-relay-2023-41332, BIT-hubble-ui-2023-41332, BIT-hubble-ui-backend-2023-41332, GHSA-24m5-r6hv-ccgp, GO-2023-2079

## What is CVE-2023-41332?

CVE-2023-41332 is a low-severity denial of service vulnerability in cilium, published on 26 Sep 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. In Cilium clusters where Cilium's Layer 7 proxy has been disabled, creating workloads with `policy.cilium.io/proxy-visibility` annotations (in Cilium >= v1.13) or `io.cilium.proxy-visibility` annotations (in Cilium <= v1.12) causes the Cilium agent to segfault on the node to which the workload is assigned. Existing traffic on the affected node will continue to flow, but the Cilium agent on the node will not able to process changes to workloads running on the node. This will also prevent workloads from being able to start on the affected node. The denial of service will be limited to the node on which the workload is scheduled, however an attacker may be able to schedule workloads on the node of their choosing, which could lead to targeted attacks. This issue has been resolved in Cilium versions 1.14.2, 1.13.7, and 1.12.14. Users unable to upgrade can avoid this denial of service attack by enabling the Layer 7 proxy.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2023-41332?

14 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium` | Go | All versions | 1.12.14, 1.13.7, 1.14.2 |
| `github.com/cilium/cilium` | Go | All versions | 1.12.14 |
| `github.com/cilium/cilium` | Go | All versions | 1.12.14 |
| `github.com/cilium/cilium` | Go | From 1.13.0 | 1.13.7 |
| `github.com/cilium/cilium` | Go | From 1.13.0 | 1.13.7 |
| `github.com/cilium/cilium` | Go | From 1.14.0 | 1.14.2 |
| `github.com/cilium/cilium` | Go | From 1.14.0 | 1.14.2 |
| `cilium` | Bitnami | All versions | 1.12.14, 1.13.7, 1.14.2 |
| `cilium-operator` | Bitnami | All versions | 1.12.14, 1.13.7, 1.14.2 |
| `cilium-proxy` | Bitnami | All versions | 1.12.14, 1.13.7, 1.14.2 |
| `hubble` | Bitnami | All versions | 1.12.14, 1.13.7, 1.14.2 |
| `hubble-relay` | Bitnami | All versions | 1.12.14, 1.13.7, 1.14.2 |
| `hubble-ui` | Bitnami | All versions | 1.12.14, 1.13.7, 1.14.2 |
| `hubble-ui-backend` | Bitnami | All versions | 1.12.14, 1.13.7, 1.14.2 |

Products: Cilium Cilium.

## How do I fix CVE-2023-41332?

Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.12.14, 1.13.7 or 1.14.2.

## Is CVE-2023-41332 being exploited?

There is no known exploitation of CVE-2023-41332 in the wild and no public exploit code.

## Other vulnerabilities in cilium

- [CVE-2026-49445](https://insights.sbomify.com/CVE-2026-49445/): Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access (critical 9.2)
- [CVE-2022-29178](https://insights.sbomify.com/CVE-2022-29178/): Incorrect Default Permissions in Cilium (high 8.8)
- [CVE-2024-28860](https://insights.sbomify.com/CVE-2024-28860/): Insecure IPsec transport encryption in Cilium (high 8.0)
- [CVE-2026-41520](https://insights.sbomify.com/CVE-2026-41520/): Cillium exposes sensitive information included in the cilium-bugtool debug archive (high 7.9)
- [CVE-2024-37307](https://insights.sbomify.com/CVE-2024-37307/): Cilium leaks sensitive information in cilium-bugtool (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41332 and fix it if it is affected.

What it is: CVE-2023-41332 is a low-severity denial of service vulnerability in cilium, published on 26 Sep 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-41332 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.12.14, 1.13.7, 1.14.2
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.12.14
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.12.14
- github.com/cilium/cilium (Go): affected from 1.13.0; fixed in 1.13.7
- github.com/cilium/cilium (Go): affected from 1.13.0; fixed in 1.13.7
- github.com/cilium/cilium (Go): affected from 1.14.0; fixed in 1.14.2
- github.com/cilium/cilium (Go): affected from 1.14.0; fixed in 1.14.2
- cilium (Bitnami): affected all versions; fixed in 1.12.14, 1.13.7, 1.14.2
- cilium-operator (Bitnami): affected all versions; fixed in 1.12.14, 1.13.7, 1.14.2
- cilium-proxy (Bitnami): affected all versions; fixed in 1.12.14, 1.13.7, 1.14.2
- hubble (Bitnami): affected all versions; fixed in 1.12.14, 1.13.7, 1.14.2
- hubble-relay (Bitnami): affected all versions; fixed in 1.12.14, 1.13.7, 1.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41332/ (Markdown: https://insights.sbomify.com/CVE-2023-41332/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41332
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41332
- OSV: https://osv.dev/vulnerability/CVE-2023-41332

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41332/
Summaries are generated and may contain mistakes; the official description above is the record.
