# CVE-2023-41335: Temporary storage of plaintext passwords during password changes in matrix synapse

> Attackers with database access can read plaintext passwords from backups during password changes, exposing user credentials.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Sep 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-4f74-84v3-j9q5, PYSEC-2023-185, UBUNTU-CVE-2023-41335

## What is CVE-2023-41335?

CVE-2023-41335 is a low-severity vulnerability in Fedoraproject Fedora, published on 26 Sep 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Synapse is an open-source Matrix homeserver written and maintained by the Matrix.org Foundation. When users update their passwords, the new credentials may be briefly held in the server database. While this doesn't grant the server any added capabilities—it already learns the users' passwords as part of the authentication process—it does disrupt the expectation that passwords won't be stored in the database. As a result, these passwords could inadvertently be captured in database backups for a longer duration. These temporarily stored passwords are automatically erased after a 48-hour window. This issue has been addressed in version 1.93.0. Users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2023-41335?

3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | From 1.66.0 | 1.93.0 |
| `matrix-synapse` | PyPI | From 1.66.0 | 1.93.0 |
| `matrix-synapse` | PyPI | From 1.66.0 | 1.93.0 |

Products: Fedoraproject Fedora, Matrix Synapse.

## How do I fix CVE-2023-41335?

Upgrade matrix-synapse to 1.93.0 or later.

## Is CVE-2023-41335 being exploited?

There is no known exploitation of CVE-2023-41335 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41335 and fix it if it is affected.

What it is: CVE-2023-41335 is a low-severity vulnerability in Fedoraproject Fedora, published on 26 Sep 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-41335 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected from 1.66.0; fixed in 1.93.0
- matrix-synapse (PyPI): affected from 1.66.0; fixed in 1.93.0
- matrix-synapse (PyPI): affected from 1.66.0; fixed in 1.93.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41335/ (Markdown: https://insights.sbomify.com/CVE-2023-41335/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41335
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41335
- OSV: https://osv.dev/vulnerability/CVE-2023-41335

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41335/
Summaries are generated and may contain mistakes; the official description above is the record.
