{"answers":{"affected":"2 open source packages ship an affected version, including symfony/ux-autocomplete. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-41336 in the wild and no public exploit code.","fix":"Upgrade symfony/ux-autocomplete to 2.11.2 or later.","what":"CVE-2023-41336 is a medium-severity vulnerability in symfony ux-autocomplete, published on 11 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-41336 and fix it if it is affected.\n\nWhat it is: CVE-2023-41336 is a medium-severity vulnerability in symfony ux-autocomplete, published on 11 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-41336 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- symfony/ux-autocomplete (Packagist): affected all versions; fixed in 2.11.2\n- symfony/ux-autocomplete (Packagist): affected all versions; fixed in 2.11.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-41336/ (Markdown: https://insights.sbomify.com/CVE-2023-41336/index.md)","id":"CVE-2023-41336","markdown":"https://insights.sbomify.com/CVE-2023-41336/index.md","name":"CVE-2023-41336","record":{"aliases":["GHSA-4cpv-669c-r79x"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Symfony UX Autocomplete","requires_auth":"none","summary":"Attackers can submit invalid entity IDs in autocomplete fields, bypassing validation and potentially modifying data in Symfony applications.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ux_autocomplete","vendor":"symfony"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"ux-autocomplete is a JavaScript Autocomplete functionality for Symfony. Under certain circumstances, an attacker could successfully submit an entity id for an `EntityType` that is *not* part of the valid choices. The problem has been fixed in `symfony/ux-autocomplete` version 2.11.2.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Prevent injection of invalid entity ids for \"autocomplete\" fields in symfony ux-autocomplete","id":"CVE-2023-41336","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"business_logic","year":"2023"},"n_packages":2,"n_references":4,"next":{"headline":"h2o vulnerable to TLS session resumption misdirection","id":"CVE-2023-41337"},"packages":[{"ecosystem":"Packagist","fixed":["2.11.2"],"introduced":["0"],"last_affected":[],"package":"symfony/ux-autocomplete","purl":null,"source":"GHSA-4cpv-669c-r79x"},{"ecosystem":"Packagist","fixed":["2.11.2"],"introduced":["0"],"last_affected":[],"package":"symfony/ux-autocomplete","purl":"pkg:composer/symfony/ux-autocomplete","source":"GHSA-4cpv-669c-r79x"}],"prev":{"headline":"Temporary storage of plaintext passwords during password changes in matrix synapse","id":"CVE-2023-41335"},"products":["ux-autocomplete"],"published":"2023-09-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-26","vendors":["symfony"]},"summary":"Attackers can submit invalid entity IDs in autocomplete fields, bypassing validation and potentially modifying data in Symfony applications.","url":"https://insights.sbomify.com/CVE-2023-41336/"}