# CVE-2023-41336: Prevent injection of invalid entity ids for "autocomplete" fields in symfony ux-autocomplete

> Attackers can submit invalid entity IDs in autocomplete fields, bypassing validation and potentially modifying data in Symfony applications.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Sep 2023
- **Updated:** 26 Sep 2024
- **Also known as:** GHSA-4cpv-669c-r79x

## What is CVE-2023-41336?

CVE-2023-41336 is a medium-severity vulnerability in symfony ux-autocomplete, published on 11 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ux-autocomplete is a JavaScript Autocomplete functionality for Symfony. Under certain circumstances, an attacker could successfully submit an entity id for an `EntityType` that is *not* part of the valid choices. The problem has been fixed in `symfony/ux-autocomplete` version 2.11.2.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-41336?

2 open source packages ship an affected version, including symfony/ux-autocomplete. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/ux-autocomplete` | Packagist | All versions | 2.11.2 |
| `symfony/ux-autocomplete` | Packagist | All versions | 2.11.2 |

Products: Symfony Ux Autocomplete.

## How do I fix CVE-2023-41336?

Upgrade symfony/ux-autocomplete to 2.11.2 or later.

## Is CVE-2023-41336 being exploited?

There is no known exploitation of CVE-2023-41336 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41336 and fix it if it is affected.

What it is: CVE-2023-41336 is a medium-severity vulnerability in symfony ux-autocomplete, published on 11 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-41336 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/ux-autocomplete (Packagist): affected all versions; fixed in 2.11.2
- symfony/ux-autocomplete (Packagist): affected all versions; fixed in 2.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41336/ (Markdown: https://insights.sbomify.com/CVE-2023-41336/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41336
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41336
- OSV: https://osv.dev/vulnerability/CVE-2023-41336

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41336/
Summaries are generated and may contain mistakes; the official description above is the record.
