# CVE-2023-41338: Vulnerability in Ctx.IsFromLocal() in gofiber

> Attackers can bypass localhost restrictions in gofiber by spoofing the X-Forwarded-For header, gaining unauthorized access to protected resources.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2023
- **Updated:** 26 Sep 2024
- **Also known as:** GHSA-3q5p-3558-364f, GO-2023-2052

## What is CVE-2023-41338?

CVE-2023-41338 is a medium-severity authentication bypass vulnerability in gofiber fiber, published on 8 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fiber is an Express inspired web framework built in the go language. Versions of gofiber prior to 2.49.2 did not properly restrict access to localhost. This issue impacts users of our project who rely on the `ctx.IsFromLocal` method to restrict access to localhost requests. If exploited, it could allow unauthorized access to resources intended only for localhost. Setting `X-Forwarded-For: 127.0.0.1` in a request from a foreign host, will result in true for `ctx.IsFromLocal`. Access is limited to the scope of the affected process. This issue has been patched in version `2.49.2` with commit `b8c9ede6`. Users are advised to upgrade. There are no known workarounds to remediate this vulnerability without upgrading to the patched version.

Weakness: CWE-670 (Always-Incorrect Control Flow Implementation)

## Which versions are affected by CVE-2023-41338?

5 open source packages ship an affected version, including github.com/gofiber/fiber/v2 and github.com/gofiber/fiber. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gofiber/fiber/v2` | Go | All versions | 2.49.2 |
| `github.com/gofiber/fiber/v2` | Go | All versions | 2.49.2 |
| `github.com/gofiber/fiber/v2` | Go | All versions | 2.49.2-0.20230906112033-b8c9ede6efa2 |
| `github.com/gofiber/fiber` | Go | All versions to 1.14.6 | None |
| `github.com/gofiber/fiber` | Go | All versions to 1.14.6 | None |

Products: Gofiber Fiber.

## How do I fix CVE-2023-41338?

Upgrade github.com/gofiber/fiber/v2 to a fixed version for your release line: 2.49.2 or 2.49.2-0.20230906112033-b8c9ede6efa2.

## Is CVE-2023-41338 being exploited?

There is no known exploitation of CVE-2023-41338 in the wild and no public exploit code.

## Other vulnerabilities in gofiber fiber

- [CVE-2024-38513](https://insights.sbomify.com/CVE-2024-38513/): Fiber Session Middleware Token Injection Vulnerability (critical 10.0)
- [CVE-2023-45128](https://insights.sbomify.com/CVE-2023-45128/): CSRF Token Reuse Vulnerability in fiber (critical 10.0)
- [CVE-2024-25124](https://insights.sbomify.com/CVE-2024-25124/): Fiber has Insecure CORS Configuration, Allowing Wildcard Origin with Credentials (critical 9.4)
- [CVE-2025-66630](https://insights.sbomify.com/CVE-2025-66630/): Fiber insecurely fallsback in utils.UUIDv4() / utils.UUID() — predictable / zero‑UUID on crypto/rand failure (critical 9.2)
- [CVE-2025-54801](https://insights.sbomify.com/CVE-2025-54801/): Fiber Susceptible to Crash via `BodyParser` Due to Unvalidated Large Slice Index in Decoder (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41338 and fix it if it is affected.

What it is: CVE-2023-41338 is a medium-severity authentication bypass vulnerability in gofiber fiber, published on 8 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-41338 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/gofiber/fiber/v2 (Go): affected all versions; fixed in 2.49.2
- github.com/gofiber/fiber/v2 (Go): affected all versions; fixed in 2.49.2
- github.com/gofiber/fiber/v2 (Go): affected all versions; fixed in 2.49.2-0.20230906112033-b8c9ede6efa2
- github.com/gofiber/fiber (Go): affected all versions up to 1.14.6; no fix listed
- github.com/gofiber/fiber (Go): affected all versions up to 1.14.6; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41338/ (Markdown: https://insights.sbomify.com/CVE-2023-41338/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41338
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41338
- OSV: https://osv.dev/vulnerability/CVE-2023-41338

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41338/
Summaries are generated and may contain mistakes; the official description above is the record.
