CVE-2023-4136 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in Crafter Engine
Reflected XSS in CrafterCMS Engine allows attackers to execute arbitrary scripts in user browsers, requiring an upgrade to secure versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-4136?
CVE-2023-4136 is a high-severity cross-site scripting vulnerability in CrafterCMS, published on 3 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CrafterCMS Engine on Windows, MacOS, Linux, x86, ARM, 64 bit allows Reflected XSS.This issue affects CrafterCMS: from 4.0.0 through 4.0.2, from 3.1.0 through 3.1.27.
Weakness: CWE-79
Which versions are affected by CVE-2023-4136?
4 open source packages ship an affected version, including org.craftercms:crafter-engine. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.craftercms:crafter-engine Maven | From 3.1.0 | 3.1.28 |
org.craftercms:crafter-engine Maven | From 3.1.0 | 3.1.28 |
org.craftercms:crafter-engine Maven | From 4.0.0 | 4.0.3 |
org.craftercms:crafter-engine Maven | From 4.0.0 | 4.0.3 |
Products include Craftercms Craftercms.
How do I fix CVE-2023-4136?
Upgrade org.craftercms:crafter-engine to a fixed version for your release line: 3.1.28 or 4.0.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-4136 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4136 exists.
Public exploit code: 1 Nuclei template.
Other vulnerabilities in CrafterCMS
Sources
Also known as GHSA-jfm4-3vv3-fm4v.