{"answers":{"affected":"4 open source packages ship an affected version, including org.craftercms:crafter-engine. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4136 exists.","fix":"Upgrade org.craftercms:crafter-engine to a fixed version for your release line: 3.1.28 or 4.0.3.","what":"CVE-2023-4136 is a high-severity cross-site scripting vulnerability in CrafterCMS, published on 3 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-4136 and fix it if it is affected.\n\nWhat it is: CVE-2023-4136 is a high-severity cross-site scripting vulnerability in CrafterCMS, published on 3 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4136 exists.\n\nAffected packages and fixed versions:\n- org.craftercms:crafter-engine (Maven): affected from 3.1.0; fixed in 3.1.28\n- org.craftercms:crafter-engine (Maven): affected from 3.1.0; fixed in 3.1.28\n- org.craftercms:crafter-engine (Maven): affected from 4.0.0; fixed in 4.0.3\n- org.craftercms:crafter-engine (Maven): affected from 4.0.0; fixed in 4.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-4136/ (Markdown: https://insights.sbomify.com/CVE-2023-4136/index.md)","id":"CVE-2023-4136","markdown":"https://insights.sbomify.com/CVE-2023-4136/index.md","name":"CVE-2023-4136","record":{"aliases":["GHSA-jfm4-3vv3-fm4v"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"CrafterCMS Engine","requires_auth":"none","summary":"Reflected XSS in CrafterCMS Engine allows attackers to execute arbitrary scripts in user browsers, requiring an upgrade to secure versions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"crafter","cpe":[{"product":"craftercms","vendor":"craftercms"}],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CrafterCMS Engine on Windows, MacOS, Linux, x86, ARM, 64 bit allows Reflected XSS.This issue affects CrafterCMS: from 4.0.0 through 4.0.2, from 3.1.0 through 3.1.27.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2023/CVE-2023-4136.yaml","stars":null,"title":"CrafterCMS Engine - Cross-Site Scripting"}],"tier":"weaponised"},"has_fix":true,"headline":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in Crafter Engine","id":"CVE-2023-4136","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":4,"n_references":3,"next":{"headline":"Allocation of Resources Without Limits or Throttling in ikus060/rdiffweb","id":"CVE-2023-4138"},"packages":[{"ecosystem":"Maven","fixed":["3.1.28"],"introduced":["3.1.0"],"last_affected":[],"package":"org.craftercms:crafter-engine","purl":null,"source":"GHSA-jfm4-3vv3-fm4v"},{"ecosystem":"Maven","fixed":["3.1.28"],"introduced":["3.1.0"],"last_affected":[],"package":"org.craftercms:crafter-engine","purl":"pkg:maven/org.craftercms/crafter-engine","source":"GHSA-jfm4-3vv3-fm4v"},{"ecosystem":"Maven","fixed":["4.0.3"],"introduced":["4.0.0"],"last_affected":[],"package":"org.craftercms:crafter-engine","purl":null,"source":"GHSA-jfm4-3vv3-fm4v"},{"ecosystem":"Maven","fixed":["4.0.3"],"introduced":["4.0.0"],"last_affected":[],"package":"org.craftercms:crafter-engine","purl":"pkg:maven/org.craftercms/crafter-engine","source":"GHSA-jfm4-3vv3-fm4v"}],"prev":{"headline":"Out-of-bounds read information disclosure vulnerability","id":"CVE-2023-4135"},"products":["CrafterCMS"],"published":"2023-08-03","related":[{"cvss_score":7.3,"headline":"Improper Control of Dynamically-Managed Code Resources in Crafter Studio","id":"CVE-2025-6384","kev_date_added":null,"published":"2025-06-19"},{"cvss_score":6.9,"headline":"Transmission of Private Resources into a New Sphere in Crafter Engine","id":"CVE-2025-0502","kev_date_added":null,"published":"2025-01-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["CrafterCMS"]},"summary":"Reflected XSS in CrafterCMS Engine allows attackers to execute arbitrary scripts in user browsers, requiring an upgrade to secure versions.","url":"https://insights.sbomify.com/CVE-2023-4136/"}